Ask Your Question
0

rviz-for-android

asked 2015-02-24 04:49:16 -0500

zior89 gravatar image

updated 2015-02-24 04:55:52 -0500

hi guys,

I´m working in a project in which i have to run rviz in a tablet. I´m using ( http://www.willowgarage.com/blog/2012... ) app. But in the app i don't received any date.

i'm working with indigo and ubuntu 14.04. i'm trying the next steps:

1) i run my simulation in rviz in my pc to show if my program show something.

2) i run server.py

3) i run tf_throttle that the app required.

and to finish i run the app of rviz on my tablet.

the app ask me for a ip. we try doing it by wifi connection. We make netstat to show if the connection is working or not and in the state it say is established but no dates are sending or receiving.

Proto Recv-Q Send-Q Local Address Foreign Address State

tcp 0 0 192.168.8.1:53803 192.168.8.10:49342 ESTABLISHED

In the app in the status of a display that is working in the rviz of the pc say No PointCloud messages received.

what could i try to make the application work?

thanks very much.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2015-02-24 05:20:19 -0500

gvdhoorn gravatar image

This could be a classic ROS-on-Android network configuration issue. See:

for some other questions about this.

In short: make sure that you either have a properly setup DNS (where both your Android device and your ROS master can resolve each other's hostnames), or force the ROS master to use bare IPs for everything, using appropriate values for ROS_IP and ROS_MASTER_URI.

edit flag offensive delete link more
0

answered 2015-02-24 08:36:54 -0500

zior89 gravatar image

But where i have to put that?

I have already done

export ROS_MASTER_URI=http://192.168.8.1:11311

export ROS_HOSTNAME=192.168.8.1

i put it in .bashrc, but in the tablet i can do it by commands. The APP ask me at first the ros_master_uri i understand. So i put what i export in .bashrc and it doesn't work.

edit flag offensive delete link more

Comments

Please don't use answers to post comments. Use the add comment button for that.

Also: I said this could be a network issue. But in any case: I'd set ROS_IP to what you have now. On the tablet, you indeed use http://192.168.8.1:11311. Can your tablet receive other msgs?

gvdhoorn gravatar image gvdhoorn  ( 2015-02-24 10:36:54 -0500 )edit

thanks very much! at least we could do it. It was our simulation problem, It wasn't any problem with the IP. Thanks a lot!

zior89 gravatar image zior89  ( 2015-02-25 02:08:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-02-24 04:49:16 -0500

Seen: 1,383 times

Last updated: Feb 24 '15