ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Failed to load plugin

asked 2015-02-22 11:00:23 -0500

HassanNadeem gravatar image

updated 2015-02-22 22:42:21 -0500

I am following the Explore the Gazebo world tutorial of turtlebot_simulator in ROS Indigo. Whenever I try to launch roslaunch turtlebot_gazebo turtlebot_world.launch I get the following error

Error [Plugin.hh:156] Failed to load plugin cannot open shared object file: No such file or directory

I have ros-indigo-gazebo-ros-control installed. What do I do to fix this?

Edit: I have also tried compiling from source.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2015-02-22 23:17:25 -0500

HassanNadeem gravatar image

Installing turtlebot_create_desktop from source solved the problem.

edit flag offensive delete link more


i tried this one but still i face this problem Do you have any solution????

isankad1990 gravatar image isankad1990  ( 2017-07-17 11:00:56 -0500 )edit

@isankad1990 if this didn't solve your issue you should ask a new question. The answerer (who also asked the question) clearly marked this answer as correct for them.

jayess gravatar image jayess  ( 2017-08-08 13:34:59 -0500 )edit

answered 2015-02-22 12:34:22 -0500

rnunziata gravatar image

Try this do a sudo find . / -name make sure the directory its in is /opt/ros/indigo/lib/

edit flag offensive delete link more


find command returns no results! Am i right in assuming that the plugin is found in ros-indigo-gazebo-ros-control package.

HassanNadeem gravatar image HassanNadeem  ( 2015-02-22 22:30:23 -0500 )edit

Hi, did you resolve this issue? How do I fix it?

robot_commander gravatar image robot_commander  ( 2017-02-27 10:26:49 -0500 )edit

Question Tools

1 follower


Asked: 2015-02-22 11:00:23 -0500

Seen: 2,294 times

Last updated: Feb 22 '15