Ask Your Question
0

No Transform to fixed frame map

asked 2015-02-22 10:17:35 -0500

rnunziata gravatar image

updated 2015-02-22 10:58:05 -0500

I am getting a transform error which I have not seen in hydro. I am having difficulty understanding the origin of this error. I am sending a scan to slam gmapping. Thank you for looking at this.

Transform [sender=unknown_publisher]
For frame [tower_link]: No transform to fixed frame [map]. TF error: [Lookup would require extrapolation into the future. Requested time 539.126000000 but the latest data is at time 539.089000000, when looking up transform from frame [tower_link] to frame [map]]

changed my tf freq on my static transforms from 100 to 10 and get the following error ...but why would it need a freq at all...its static? Why does it change the results. Changing the "map_update_interval" does not fix this either. I am not understanding something can someone please explain?

Transform [sender=unknown_publisher]
For frame [tower_link]: No transform to fixed frame [map]. TF error: [Lookup would require extrapolation into the future. Requested time 529.203000000 but the latest data is at time 529.200000000, when looking up transform from frame [tower_link] to frame [map]]
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2015-02-22 13:42:46 -0500

rnunziata gravatar image

Apparently this was related to ekf_pose and my pose rate once I increased it to 30 form 10 this problem resolved.

edit flag offensive delete link more

Comments

Thank you so much bro, this is very helpful

أسامة الادريسي gravatar image أسامة الادريسي  ( 2017-11-06 10:59:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-02-22 10:17:35 -0500

Seen: 2,160 times

Last updated: Feb 22 '15