ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
0

MoveIt! Installation

asked 2015-02-21 13:32:51 -0500

vkee gravatar image

updated 2015-02-22 02:36:32 -0500

gvdhoorn gravatar image

Hi,

I've been trying to install MoveIt! on ROS Indigo in Ubuntu 14.04 and have been running into issues.

I first tried to install it using the binary installation instructions: sudo apt-get install ros-indigo-moveit-ros However, it says:

*Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 ros-indigo-moveit-full : Depends: ros-indigo-moveit-commander but it is not going to be installed
                          Depends: ros-indigo-moveit-ros but it is not going to be installed
                          Depends: ros-indigo-moveit-setup-assistant but it is not going to be installed*

I have also tried installing it from source. It seemed to work after a few times but when I try to run a tutorial program, it says "ImportError: No module named moveit_commander"

I tried reinstalling ROS multiple times to no avail.

I've been looking around online but it seems like other people are having similar issues. Has any been able to successfully install MoveIt?

Thanks

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2017-01-17 06:03:06 -0500

130s gravatar image

python-pyassimp became available for Trusty sometime ago so for Indigo this issue should be resolved (ie. you don't need to bother yourself building moveit_commander from source).

Note for ROS Kinetic users; there's an open issue again regarding pyassimp.

edit flag offensive delete link more
4

answered 2015-07-05 20:45:16 -0500

jackie gravatar image

I ran into the same problem installing ros-indigo-moveit-python and ros-indigo-moveit-commander from debians on 14.04.

The problem is that the version of libassimp3 that these packages depend on (via their dependency on python-pyassimp) is not provided by the package manager on Trusty.

To fix this manually, download libassimp3_3.0~dfsg-3_amd64.deb from here: https://launchpad.net/ubuntu/+source/...

then install it using sudo dpkg -i. You should then be able to install ros-indigo-moveit-full and/or the packages included in the metapackage that depend on libassimp3.

edit flag offensive delete link more
0

answered 2015-05-29 02:19:04 -0500

timbo gravatar image

Your install has some sort of issue with a package dependency. ros-indigo-moveit-full is a metapackage i.e. it is an umbrella for actual packages like ros-indigo-moveit-commander, etc. I would try and install packages individually and that should help identify where the problem lies.

If you have built from source successfully, then the moveit_commander module (which is a python module like any other python module) should be in a python 'dist-packages' directory. You can see all the module directories that Python looks in with "import sys; sys.path". ROS puts all of its modules in /opt/ros/<ros-version>/lib/python2.7/dist-packages but as moveit is separately built, you should see moveit-commander in /usr/local/lib/python2.7/dist-packages/

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-02-21 13:32:51 -0500

Seen: 1,817 times

Last updated: Jan 17 '17