Ask Your Question
2

process crashes, no log file where it says

asked 2015-02-19 16:54:09 -0600

chris_ gravatar image

When I change some parameters in some octomap_server initialization code, I get a crash which I can't debug.

[octomap_server-2] process has died [pid 22734, exit code -6, cmd /home/chris/ros_ws/devel/lib/octomap_server/octomap_server_node cloud_in:=/cloud __name:=octomap_server __log:=/home/chris/.ros/log/798b4038-b889-11e4-97b4-b8ca3a7c5dcb/octomap_server-2.log].
log file: /home/chris/.ros/log/798b4038-b889-11e4-97b4-b8ca3a7c5dcb/octomap_server-2*.log\

I would normally just use the log file it tells me, but for the node that crashed there is no log file in the directory it specifies. I have grep'd all the source code for exit(-6) etc and can't find anything. Any suggestions how I can actually see why its crashing?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-02-19 17:03:09 -0600

Did you try running the process through a debugger? E.g, if you are using a roslaunch file, try adding gdb to the launch-prefix. http://wiki.ros.org/roslaunch/Tutoria...

edit flag offensive delete link more

Comments

wasn't aware of this, this explains everything.

chris_ gravatar imagechris_ ( 2015-02-19 17:06:46 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-02-19 16:54:09 -0600

Seen: 1,436 times

Last updated: Feb 19 '15