Ask Your Question
0

Dependency error while installing Indigo on Ubuntu 14.04

asked 2015-02-18 09:31:36 -0500

VahidD gravatar image

updated 2017-11-03 17:41:39 -0500

ahendrix gravatar image

Hi there,

I want to install indigo on ubuntu 14.04 but i have dependency problem, maybe someone can help me out. for installation i followed instruction in ros page. just i can install ros_base. Also i tried current solution but they don't work!

vahid@vahid:~$ sudo apt-get install ros-indigo-desktop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-indigo-desktop : Depends: ros-indigo-rqt-common-plugins but it is not going to be installed
                      Depends: ros-indigo-rqt-robot-plugins but it is not going to be installed
                      Depends: ros-indigo-visualization-tutorials but it is not going to be installed
                      Depends: ros-indigo-viz but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

vahid@vahid:~$ uname -m
x86_64

vahid@vahid:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.1 LTS
Release:    14.04
Codename:   trusty

i tried also with synaptic, but it wants to remove these packages:

cheese will be removed
compiz will be removed
compiz-gnome will be removed
compiz-plugins-default will be removed
gir1.2-totem-1.0 will be removed
gstreamer1.0-vaapi will be removed
libgl1-mesa-dri:i386 will be removed
libgl1-mesa-glx:i386 will be removed
libglapi-mesa:i386 will be removed
libglew1.10 will be removed
libglewmx1.10 will be removed
libgstreamer-vaapi1.0-0 will be removed
libnux-4.0-0 will be removed
libqt4-opengl:i386 will be removed
libqtwebkit4:i386 will be removed
libreoffice-ogltrans will be removed
libtotem0 will be removed
libunity-core-6.0-9 will be removed
libva-glx1 will be removed
libvisual-0.4-plugins will be removed
nux-tools will be removed
skype will be removed
skype-bin:i386 will be removed
totem will be removed
totem-mozilla will be removed
totem-plugins will be removed
ubuntu-desktop will be removed
unity will be removed
unity-lens-applications will be removed
xorg will be removed
edit retag flag offensive close merge delete

Comments

Did you solve this problem.? Ryt now i am facing the same

minhaj falaki gravatar image minhaj falaki  ( 2017-10-10 13:03:47 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2017-11-03 17:39:02 -0500

Steven Wei gravatar image

I met this problem yesterday, when I upgraded OpenCV and some ROS dependencies were broken. What I did is to use aptitude instead of apt-get. It is more intelligent, and can give you some suggestions to resolve the problem. Probably, you have some low-level packages version mismatch, so apt-get refuse to install ROS.

Try

$ sudo apt-get install aptitude

$ sudo aptitude install ros-indigo-desktop

Then you will see the lowest unmet dependencies as well as the suggestions. Pressing n to refuse its first suggestion, cause the first suggestion usually does nothing, aptitude will give your more suggestions every time you refuse. Choose one suggestion you like.

Also, you may have to run $ sudo aptitude install ros-indigo-desktop and select one suggestion several times to solve the problem.

edit flag offensive delete link more

Comments

Thank you bro

أسامة الادريسي gravatar image أسامة الادريسي  ( 2017-11-04 01:15:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-02-18 09:31:36 -0500

Seen: 890 times

Last updated: Nov 03 '17