Ask Your Question
0

Spawning hector quadrotor crashes gazebo on indigo [closed]

asked 2015-02-08 02:12:23 -0500

rock-ass gravatar image

updated 2015-02-08 02:14:02 -0500

Hi,

I was trying to start hector quadrotor demo launch files and keep getting gazebo segmentation faults when the script tries to spawn quadrotor. After some time I have tried to spawn it on my own using these launch files:

roslaunch gazebo_ros empty_world.launch
roslaunch hector_quadrotor_gazebo spawn_quadrotor.launch

But even then the gazebo server crashes with following error:

spawn_model script started
[INFO] [WallTime: 1423382867.059244] [0.000000] Loading model xml from ros parameter
[INFO] [WallTime: 1423382867.061820] [0.000000] Waiting for service /gazebo/spawn_urdf_model
[INFO] [WallTime: 1423382867.064229] [0.000000] Calling service /gazebo/spawn_urdf_model
[INFO] [WallTime: 1423382867.111548] [0.000000] Controller Spawner: Waiting for service controller_manager/load_controller
Segmentation fault (core dumped)
Service call failed: transport error completing service call: unable to receive data from sender, check sender's logs for details
[gazebo-1] process has died [pid 24654, exit code 139, cmd /opt/ros/indigo/lib/gazebo_ros/gzserver worlds/empty.world __name:=gazebo __log:=/home/rokas/.ros/log/25359450-af08-11e4-930f-fcf8ae311424/gazebo-1.log].

The log files after the error is empty, so I can't traceback what happening. But it seems like spawning quadrotor crashes the gzserver.

I have tried using the packages installed via apt-get and then tried with latest version of hector_quadrotor from github and the problem persists. Maybe some of you will have some ideas on this problem?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-08-28 03:21:47.978213

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-08-05 16:14:47 -0500

jessiems10 gravatar image

Have you tried making sure that all of the need files are downloaded for the demo? When I was running into building errors, I did

$ sudo apt-get remove ros-indigo-hector-

Then hit the tab button till I got the list of all installed hector related packages (be careful not to remove anything). I was missing some of the packages so as soon as I sudo apt-get install the rest, my errors went away.

But, the way your error is presented, you maybe missing the controller package for gazebo.

$ sudo apt-get install ros-indigo-hector-quadrotor-controller
$ sudo apt-get install ros-indigo-hector-quadrotor-controller-gazebo
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-02-08 02:12:23 -0500

Seen: 925 times

Last updated: Aug 05 '15