ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

robot-upstart indigo

asked 2015-02-02 06:51:49 -0600

julien gravatar image


I'm trying to use upstart to run my robot application at the startup of the system but I can't configure it. I currently have my catkin workspace with my tool at /home/robot/workspace and when I run the command:

$rosrun robot_upstart install workspace/src/safe_pilot/launcher/safe_pilot.launch

I have the error:

Unable to located path src/safe_pilot/launcher/safe_pilot.launch in package workspace. Installation aborted. Traceback (most recent call last): File "/opt/ros/indigo/lib/robot_upstart/install", line 32, in <module> exit(main()) File "/opt/ros/indigo/lib/python2.7/dist-packages/robot_upstart/", line 83, in main if os.path.isfile(found_path[0]): IndexError: list index out of range

Does someone has an idea??


edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2015-02-03 03:04:20 -0600

BennyRe gravatar image

The argument to robot_upstart install is pkg/path.

In your case:

$rosrun robot_upstart install safe_pilot/launcher/safe_pilot.launch
edit flag offensive delete link more


tks for your answer,

Does it suppose that my package has been installed using catkin_make install ? or can I used the catkin_workspace/devel folder?

julien gravatar image julien  ( 2015-02-03 03:24:41 -0600 )edit

No you don't have to do catkin_make install. You also don't have to care about the devel folder. This command should work as it is.

BennyRe gravatar image BennyRe  ( 2015-02-03 04:19:48 -0600 )edit

Ok tks it works. Just a last question: How to remove/suspend the automatic launch... (removing manually the created files??)

julien gravatar image julien  ( 2015-02-16 04:22:59 -0600 )edit

robot_upstart includes an uninstall script.

BennyRe gravatar image BennyRe  ( 2015-02-16 04:33:23 -0600 )edit

Are you shure ? because in the GIT repository I can't see an uninstall script and the documentation don't speak about it...

I have an other question one of my node is in charge to log data in a file and when I use robot_upstart the file can't be created, does the program is run with a Read-Only opt

julien gravatar image julien  ( 2015-03-03 07:33:35 -0600 )edit

Oh I see. There was an uninstall script till Mike Purvis ported the install script to python.

BennyRe gravatar image BennyRe  ( 2015-03-03 09:58:57 -0600 )edit

The uninstall script has been restores as of v0.1.2 (not synced to public yet), so either install from the shadow repositories or do a source-install

paulbovbel gravatar image paulbovbel  ( 2015-03-16 16:08:05 -0600 )edit
Ugnius Malukas gravatar image Ugnius Malukas  ( 2017-09-28 04:07:40 -0600 )edit

answered 2015-03-16 11:48:55 -0600

julien gravatar image


I have an other question:

I have a Logging Node which is in charge to collect data and store them into a CSV file with the specific format. The output folder is /home/${user}/ . It works when I run the lanch file manually but It doesn't works when I use the robot_upstart script... I read in the robot_upstart documentation that some privileged are change, but when I user the specfic parameter --user I also avec the same problem.

Did someone has the same problem?


edit flag offensive delete link more



Please do not post other questions as answers. ROS answers is a Q&A site and not a discussion forum. Yes some stuff acts different when run from robot_upstart.

BennyRe gravatar image BennyRe  ( 2015-03-17 01:59:29 -0600 )edit

Ok sorry for my mistake, have you got an idea of this problem? I've checked that de user running the application is the same as the /home owner and it seems to be ok. I'm manipulatins file using QT.

julien gravatar image julien  ( 2015-03-17 03:28:56 -0600 )edit

no sorry no idea.

BennyRe gravatar image BennyRe  ( 2015-03-17 07:23:53 -0600 )edit

Question Tools

1 follower


Asked: 2015-02-02 06:51:49 -0600

Seen: 2,113 times

Last updated: Mar 16 '15