Ask Your Question
0

Kinect isn't visible from Odroid when battery powered (turtlebot v2)

asked 2015-01-31 15:23:57 -0500

raarenst gravatar image

I have a problem with my turtlebot 2 that is driven by an odroid U3. The problem is that the Kinect isn’t visible from the odroid. The odroid is powered from the 12V/5A connector on the kobuki base. There is a LM2596, 5V voltage regulator between. If I disconnect the voltage regulator and istead drive the odroid with a wall power supply is works perfectly. The current from the 12V source at the base is is measured to 1.5A, so current should be enough. To test I have also driven the odroid with an external 5V powerpack (charging unit for mobile devices 12000mAh, max current 3.4A), that didn’t work either. With not working I mean that the Kinect isn’t visible from the odroid, everything else works perfectly.

There are a lot of other stuff on as well; screen, 11 IR sensors, mic and camera. Everything works well regardless of power source, except the Kinect that doesn’t work when the odroid is battery driven. Everything except the things in the figure below are now disconnected not to interfere.

I have no clue and I have tested and measured everything I can think of, any ideas?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2015-03-01 04:23:06 -0500

raarenst gravatar image

updated 2015-07-01 05:00:07 -0500

After some more measurements I see that when running on battery there are loads of USB error messages during startup. Then the voltage on the USB port becomes 4.2 V, while power from a DC/DC step down regulator fed into odroid is 5.25V. Still all other USB devices works well (WiFi, camera), but not the kinect. Current to kinect is 0 A.

[Later] It didn't work with better (at least more expensive) regulators. First I thought it worked then I realized that the charging cable to the kobuki was attached. So it still doesn't work when running kobuki on battieries but it works when charging is attached. I use 2 5V/3A regulators to the 12V/5A kubuki port.

Could it be a ground problem??

edit flag offensive delete link more

Comments

1

Yeah, in my testing with other embedded boards I have made sure there's at least 3A available at 5V. 1.5A is enough for smaller peripherals but as you're observing can lead to brownouts with more/larger loads.

tfoote gravatar image tfoote  ( 2015-03-01 14:07:42 -0500 )edit

Yes, that makes sense. However, the hardkernel power supply is the only soruce that works and it is 5V/2A. Maybe it is some transient thing. I will use better DC/DC and make sure 3A is possible. Let's see what happens.

raarenst gravatar image raarenst  ( 2015-03-01 15:34:01 -0500 )edit

Did swapping the regulator work for you? Our turtlebot with Odroid U3 keeps on dying, and we're having a hell of a time debugging why. I'd imagine it's because we're using 2A regulators for the 5V and 12V rails, but we haven't been able to work it out.

nckswt gravatar image nckswt  ( 2015-06-23 11:16:04 -0500 )edit

Our own problems were fixed by using an external battery for our Odroid. We emailed the Create support team, asking for specs, and they didn't provide anything helpful except to say that the DB25 connector on the Create was limiting our current output. Might be the same issue on the Kobuki?

nckswt gravatar image nckswt  ( 2015-07-08 14:12:40 -0500 )edit

Changing regulators didn't help. I have also tried with a odroid U2 and same issue. However, I have found that it happens only when the battery is running low. It could be that the power to the kinect isn't enough for it and that the odroid works perfectly. Everything else works for quite some time.

raarenst gravatar image raarenst  ( 2015-09-12 09:29:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-31 15:23:57 -0500

Seen: 685 times

Last updated: Jul 01 '15