ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ROS does not detect packages installed with apt-get

asked 2015-01-29 10:54:16 -0500

Audren Cloitre gravatar image


I tried to install packages to ROS indigo by running the command: sudo apt-get install ros-indigo-package name

The packages are downloaded and installed but neither roscd nor rosrun can find them, despite sourcing the file setup.bash after the download.

Am I missing a step?

Best Regards

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-01-29 12:09:39 -0500

gvdhoorn gravatar image

Could be that your cache is (somehow) out-of-date. Try a rospack profile after you've sourced setup.bash.

edit flag offensive delete link more


Thank you so much gvdhoorn! It worked and ROS can now retrieve the packages installed. All good.

Audren Cloitre gravatar image Audren Cloitre  ( 2015-01-29 12:18:02 -0500 )edit

Np. Please mark the question as answered by clicking the check mark.

gvdhoorn gravatar image gvdhoorn  ( 2015-01-29 12:34:42 -0500 )edit

Question Tools

1 follower


Asked: 2015-01-29 10:54:16 -0500

Seen: 383 times

Last updated: Jan 29 '15