ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

No rule to make target `/usr/lib64/

asked 2014-12-30 16:49:10 -0600

atp gravatar image

catkin_make suddenly started to fail with the following error in Fedora 20:

[ 97%] make[2]: *** No rule to make target `/usr/lib64/', needed by XYZ

yum provides gives:

1:qt-devel-4.8.5-10.fc20.i686 : Development files for the Qt toolkit
Repo        : fedora
Matched from:
Filename    : /usr/lib/

1:qt-devel-4.8.5-10.fc20.x86_64 : Development files for the Qt toolkit
Repo        : fedora
Matched from:
Filename    : /usr/lib64/

So, both libraries are already installed.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2015-02-02 12:59:22 -0600

updated 2015-02-02 12:59:51 -0600

This is a Fedora bug in VTK packaging and was fixed:

Just update vtk-devel to the latest version.

edit flag offensive delete link more

answered 2014-12-30 17:13:40 -0600

William gravatar image

It looks like CMake generated Make code which used /usr/lib64/ as a target dependency and that since generating that Make code, that file has moved or no longer exists? I think this because typically the No rule to make target error results from a missing file that you are expecting to be there (especially since the file is obviously not built by your package). Have you tried removing your build space and building from scratch or at least passing --force-cmake to catkin_make?

Have you just double checked that the file is there? I know yum says it is, but make sure it isn't a dangling symbolic link or something of that nature.

I'll point out that this doesn't really look like a ROS or catkin issue, it appears to be solely a using Qt with CMake problem. If you don't find you answer here you might consider trying to narrow it down to a simple CMake example (without catkin) and posting to stackoverflow or something similar.

edit flag offensive delete link more


Thanks, William. Your 2nd suggestion is correct: the .so file is not in /usr/lib64. I also ran find / -name "" with no results. Any idea what to do next?

atp gravatar image atp  ( 2014-12-31 04:49:15 -0600 )edit

Question Tools


Asked: 2014-12-30 16:49:10 -0600

Seen: 910 times

Last updated: Feb 02 '15