Ask Your Question
0

Error in using rgbdslam with GUI

asked 2014-12-26 14:31:18 -0500

Morteza gravatar image

Hello,

I am trying to implement SLAM using rgbdslam. But when i run the command "roslaunch rgbdslam kinect+rgbdslam.launch" from the wiki page "http://wiki.ros.org/rgbdslam?distro=fuerte", i get the following error. I appreciate any help.

WARNING: [/home/morteza/fuerte_workspace/sandbox/rgbdslam_freiburg/rgbdslam/launch/kinect+rgbdslam.launch] unknown <node> attribute 'no_launch-prefix'

[ERROR] [1419625375.970080106]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/compressedDepth/set_parameters] [ERROR] [1419625375.977429410]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/compressed/set_parameters] [ERROR] [1419625375.988461110]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/theora/set_parameters]

REQUIRED process [rgbdslam-23] has died! process has died [pid 5256, exit code 127, cmd /home/morteza/fuerte_workspace/sandbox/rgbdslam_freiburg/rgbdslam/bin/rgbdslam __name:=rgbdslam __log:=/home/morteza/.ros/log/f811358e-8d3c-11e4-abdb-08edb96bfa77/rgbdslam-23.log]. log file: /home/morteza/.ros/log/f811358e-8d3c-11e4-abdb-08edb96bfa77/rgbdslam-23*.log Initiating shutdown!

edit retag flag offensive close merge delete

Comments

Also, when i try to start the openni nodes and RGBDSLAM separately with the commands 'roslaunch openni_launch openni.launch' and 'rosrun rgbdslam rgbdslam', I get the following error.

/home/morteza/fuerte_workspace/sandbox/rgbdslam_freiburg/rgbdslam/bin/rgbdslam: error while loading shared libraries: libsiftgpu.so: cannot open shared object file: No such file or directory

Morteza gravatar image Morteza  ( 2014-12-27 11:33:42 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-01-12 07:54:37 -0500

Hi,

the first ERROR messages are unrelated, they are from the camera driver and AFAIK can be safely ignored.

The message starting with REQUIRED more or less says that rgbdslam crashed. The message in your comment hints towards a missing library. Apparently you need to build the siftgpu library, which should have been done by rosmake. To do it manually, run make in rgbdslam/external/siftgpu/linux and copy the created external/siftgpu/linux/bin/libsiftgpu.so to a directory searched by the linker (try rgbdslam/lib or check the linker command line with make VERBOSE=1 for -L/some/dir parameters).

Also note that there's a much better version available for ROS hydro on github

edit flag offensive delete link more

Comments

Thank you for your response. I downloaded the hydro version and it works well. In fuerte i did what you said but when i ran make, although the libsiftgpu.so was made, i got error.

Morteza gravatar image Morteza  ( 2015-01-13 09:37:54 -0500 )edit

Ok, I guess that's fine then.

Felix Endres gravatar image Felix Endres  ( 2015-01-14 04:09:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-12-26 14:31:18 -0500

Seen: 420 times

Last updated: Jan 12 '15