Ask Your Question
1

freenect_launch will always stop and flush when I launch rgbdslam

asked 2014-12-24 02:25:41 -0500

wchar gravatar image

I am using ROS hydro on ubuntu 12.04 LTS. The problem is, since I'm using freenect to get depth and RGB images for rgbdslam, the freenect node will be okay if I leave it alone without any subscriber. But soon after I started processing the image in the rgbdslam node, the freenect node will stop and fall to a dead loop of:

[ INFO] [1419407643.570524704]: Device timed out. Flushing device.
[ INFO] [1419407643.570749230]: Starting a 3s RGB and Depth stream flush.
...

I'm using Kinect 1, and ubuntu is running in Parallels Desktop 10 with Mac OS X. I don't know what has caused this problem, anyone can help me? Thanks in advance.

edit retag flag offensive close merge delete

Comments

I have the same problem. Did you find a solution or a workaround for that?

Matt_Matt gravatar imageMatt_Matt ( 2015-12-15 15:24:37 -0500 )edit

Sorry for the late reply. Please refer to the answer.

wchar gravatar imagewchar ( 2016-04-28 21:00:37 -0500 )edit
1

Same issue here: MacBook Pro - virtual machine VMWare, Ubuntu 14.04, ROS indigo - what worked for me ("root cause"): USB settings: changed it to "USB 3.0" compatible and it worked! negative side effect: USB connection to Turtlebot2 broken (kobuki)...fix: connecting the kobuki via ab USB 2.0 hub

milan gravatar imagemilan ( 2016-07-16 14:42:35 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-04-28 21:00:02 -0500

wchar gravatar image

For those who's interested: solved by switching to openni with drivers installed from https://github.com/avin2/SensorKinect

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-12-24 02:25:41 -0500

Seen: 1,149 times

Last updated: Apr 28 '16