ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

problem with make ing rospack package - in mac

asked 2014-12-18 11:57:06 -0500

shahriarta gravatar image

Guys, I'm new with ROS, I knew that it does not support OS X, but I have to run that on this system, This is OS X Yosemite 10.10.1

I did all of the installation guide for ROS hydro from the first step to the 2.1.2 Resolving Dependencies, there was some problem with dependencies which I've solved with manually doing those with "brew install ....."

After that I've completely stuck in the 2.1.3 Building the catkin Workspace part and exactly in making rospack package, first there was a problem with not finding the "tinyxml.h" file which I solved that with "brew install tinyxml" and "brew install tinyxml2" and know I've stuck here.

This is the error log:

==> make -j2 -l2 in '/Users/shahriarta/ros_catkin_ws/build_isolated/rospack' Linking CXX shared library /Users/shahriarta/ros_catkin_ws/devel_isolated/rospack/lib/librospack.dylib ld: library not found for -ltinyxml clang: error: linker command failed with exit code 1 (use -v to see invocation) make[2]: * [/Users/shahriarta/ros_catkin_ws/devel_isolated/rospack/lib/librospack.dylib] Error 1 make[1]: [CMakeFiles/rospack.dir/all] Error 2 make: ** [all] Error 2 <== Failed to process package 'rospack': Command '/Users/shahriarta/ros_catkin_ws/install_isolated/ make -j2 -l2' returned non-zero exit status 2

Reproduce this error by running: ==> cd /Users/shahriarta/ros_catkin_ws/build_isolated/rospack && /Users/shahriarta/ros_catkin_ws/install_isolated/ make -j2 -l2

Command failed, exiting.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-01-19 02:57:21 -0500

jjclark gravatar image

I encountered this error and was able to make the build succeed by replacing -ltinyxml with /usr/local/lib/libtinyxml.dylib in various link.txt files within ros_catkin_ws/build_isolated/. I don't know why the linker had trouble finding that library in such a standard location.

grep -rl ' -ltinyxml' ./build_isolated | xargs sed -i.bak 's|-ltinyxml|/usr/local/lib/libtinyxml.dylib|g'
edit flag offensive delete link more


Thank you so much, It solved my problem

shahriarta gravatar image shahriarta  ( 2015-01-19 10:59:57 -0500 )edit

Question Tools

1 follower


Asked: 2014-12-18 11:57:06 -0500

Seen: 1,500 times

Last updated: Dec 18 '14