Ask Your Question
16

Problem with Indigo and Gazebo 2.2

asked 2014-12-12 15:18:50 -0500

Stefano Primatesta gravatar image

I have a problem with Gazebo 2.2. When I launch gazebo, I see this error

:~$ gazebo
Gazebo multi-robot simulator, version 2.2.3
Copyright (C) 2012-2014 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Msg Waiting for master
Gazebo multi-robot simulator, version 2.2.3
Copyright (C) 2012-2014 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Msg Waiting for master
Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 192.168.1.152
Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 192.168.1.152
Warning [ModelDatabase.cc:334] Getting models from[http://gazebosim.org/models/]. This may take a few seconds.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Error [gazebo.cc:220] Waited 11 seconds for namespaces. Giving up.
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Param.cc:181] Unable to set value [1,0471975511965976] for key[horizontal_fov]
Error [Param.cc:181] Unable to set value [0,100000001] for key[near]

How Can I solve?

Thanks

edit retag flag offensive close merge delete

8 Answers

Sort by ยป oldest newest most voted
16

answered 2014-12-15 02:21:56 -0500

Stefano Primatesta gravatar image

updated 2014-12-15 10:29:43 -0500

At the moment I replaced "http://gazebosim.org/models" in "http://old.gazebosim.org/models". Now it all works!

Thanks to all!!!

UPDATE

The best way to solve this problem is update Gazebo 2.2, but you must add packages.osrfoundation.org at Ubuntu repositories.

sudo sh -c 'echo "deb http://packages.osrfoundation.org/gazebo/ubuntu trusty main" > /etc/apt/sources.list.d/gazebo-latest.list'
wget http://packages.osrfoundation.org/gazebo.key -O - | sudo apt-key add -

Then if you update Ubuntu, It install Gazebo 2.2.5. Now it all works!

edit flag offensive delete link more

Comments

2

interesting... where did you change that link? in which file?

Andromeda gravatar imageAndromeda ( 2014-12-15 03:04:42 -0500 )edit
2

In "source /usr/local/share/gazebo-2.2/setup.sh".

I think there's a problem with http://gazebosim.org/models link.

Stefano Primatesta gravatar imageStefano Primatesta ( 2014-12-15 03:45:17 -0500 )edit

cool,it works,thanks a lot

Laszlo gravatar imageLaszlo ( 2016-11-18 01:10:42 -0500 )edit
1

I replaced it in /usr/share/gazebo and /usr/share/gazebo-2.2. Still the problem persists. Infact, gazebo stil uses the previous url

Warning [ModelDatabase.cc:334] Getting models from[http://gazebosim.org/models/]. This may take a few seconds.

Msg Connected to gazebo master @ http://127.0.0.1:1134

Anurag gravatar imageAnurag ( 2017-04-28 05:18:01 -0500 )edit

After modifying the URL you have to source the same file: source /usr/share/gazebo source /usr/share/gazebo-2.2

Safwan.Ahmad gravatar imageSafwan.Ahmad ( 2018-12-14 05:35:00 -0500 )edit
20

answered 2014-12-14 09:52:24 -0500

sontdhust gravatar image

updated 2016-04-28 01:20:54 -0500

For error

Error [Param.cc:181] Unable to set value [1,0471975511965976] for key[horizontal_fov]
Error [Param.cc:181] Unable to set value [0,100000001] for key[near]

Workaround: $ export LC_NUMERIC=C or you might want to add that line to your ~/.bashrc.

But the problem with "namespace not found", I had the same. Two days ago I installed ros indigo -> gazebo -> gazebo_ros plugin and kobuki_gazebo, everything ok. Now I reinstall them, with the bit different: first gazebo -> then ros indigo... and I encounter errors like you

Sorry for my bad English :P

UPDATE

Finally I got it! Gazebo try to collect models from http://gazebosim.org/models but there 's something wrong... the folder ~/.gazebo/models does not exist and Gazebo simulator can not start. Here's a bit more simple solution: run $ wget -r -R "index\.html*" http://old.gazebosim.org/models/

to get all models from gazebosim and copy them into ~/.gazebo/models folder (after you mkdir models inside ~/.gazebo) and everything will be ok.

UPDATE 2

See @Juni answer for better way to download models.

edit flag offensive delete link more

Comments

5

This solution worked for me. But I had to replace the link http://old.gazebosim.org/models/ with http://models.gazebosim.org/. And a better and faster way is to download the models files from bitbucket.

Juni gravatar imageJuni ( 2015-06-26 02:15:22 -0500 )edit

Oh my God... I spent half an hour downloading dozens of these models by wget >_<... thank u so muchhhh...

sontdhust gravatar imagesontdhust ( 2015-06-26 03:16:16 -0500 )edit

Thanks for your method.

ljxiang gravatar imageljxiang ( 2016-04-06 21:45:27 -0500 )edit

The step mentioned by Juni about downloading the file and unzipping it in the ~/.gazebo/models/ folder worked for me. I tried to edit the setup.sh file but couldn't find it in the specified folder. Thank you

pallavbakshi gravatar imagepallavbakshi ( 2017-02-02 11:16:45 -0500 )edit

This helped a lot. Thanks.

surfertas gravatar imagesurfertas ( 2017-03-05 20:25:39 -0500 )edit
2

answered 2016-11-18 02:27:41 -0500

mohit_rai gravatar image

updated 2016-11-18 02:31:45 -0500

Okay I have a workaround similar to one devised earlier:

sudo gedit /usr/share/gazebo-2.2/setup.sh

well it would look something like this:

export GAZEBO_MASTER_URI=http://localhost:11345
export GAZEBO_MODEL_DATABASE_URI=http://gazebosim.org/models
export GAZEBO_RESOURCE_PATH=/usr/share/gazebo-2.2:/usr/share/gazebo_models
export GAZEBO_PLUGIN_PATH=/usr/lib/i386-linux-gnu/gazebo-2.2/plugins
export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/usr/lib/i386-linux-gnu/gazebo-2.2/plugins
export OGRE_RESOURCE_PATH=/usr/lib/i386-linux-gnu/OGRE-1.8.0

you must change the "GAZEBO_MODEL_DATABASE_URI" to http://models.gazebosim.org and that's it.

I think what it does is it starts looking for namespaces on the website that you mentioned in setup.sh and then, if matched, it fetches the required models.

edit flag offensive delete link more
2

answered 2017-01-11 06:34:28 -0500

mkorkmaz gravatar image

The same problem I faced after the fresh installation of indigo. So, in home folder, press ctrl+h to see the hidden files. Then find the .gazebo file and copy the gazebo "models" file from the internet. And it worked for me.

edit flag offensive delete link more
1

answered 2018-12-30 22:29:49 -0500

plutotx gravatar image

Gazebo needs to find models, the download link in 2.2 is no longer valid, so it can't download and find the models. You can manually download the models from https://bitbucket.org/osrf/gazebo_mod... , extract it in ~/.gazebo/models/

edit flag offensive delete link more
1

answered 2015-04-19 12:36:09 -0500

Mondi gravatar image

Hallo I have the same problem. Unfortunately, none of your solutions work for me.

Here the snippet from the terminal

Gazebo multi-robot simulator, version 2.2.5
Copyright (C) 2012-2014 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

azebo multi-robot simulator, version 2.2.5
Copyright (C) 2012-2014 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

32mMsg Waiting for master
Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 10.0.2.15
Msg Waiting for master
Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 10.0.2.15
Warning [ModelDatabase.cc:334] Getting models from[http://gazebosim.org/models/]. This may take a few seconds.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Warning [gazebo.cc:215] Waited 1seconds for namespaces.
Error [gazebo.cc:220] Waited 11 seconds for namespaces. Giving up.
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Node.cc:90] No namespace found
Error [Param.cc:181] Unable to set value [1,0471975511965976] for key[horizontal_fov]
Error [Param.cc:181] Unable to set value [0,100000001] for key[near]

And the content of the setup.sh

export GAZEBO_MASTER_URI=http://localhost:11345
export GAZEBO_MODEL_DATABASE_URI=http://gazebosim.org/models
export GAZEBO_RESOURCE_PATH=/usr/share/gazebo-2.2:/usr/share/gazebo_models
export GAZEBO_PLUGIN_PATH=/usr/lib/i386-linux-gnu/gazebo-2.2/plugins
export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/usr/lib/i386-linux-gnu/gazebo-2.2/plugins
export OGRE_RESOURCE_PATH=/usr/lib/i386-linux-gnu/OGRE-1.8.0

Then for me everything looks fine, but it does't work.

Perhaps any of you has a idea to solve my problem.

Is it a problem with ubuntu 14.04.2 or with virtual box?

I am surprised that this problem has not occurred more often.

edit flag offensive delete link more

Comments

I've had the same problem. Through this link you can find more information about installing related packages.

MahsaP gravatar imageMahsaP ( 2015-08-10 12:55:47 -0500 )edit
0

answered 2014-12-13 13:32:45 -0500

Andromeda gravatar image

Did you try setting the environment variables for gazebo? I had the same problem too.

edit flag offensive delete link more
0

answered 2017-07-09 03:02:21 -0500

I disconnected to Internet and worked well. but i dont know why but there's a connection problem ;-0

or edited both /usr/share/gazebo-2.2/setup.sh /usr/share/gazebo/setup.sh

from

export GAZEBO_MASTER_URI=http://localhost:11345 export GAZEBO_MODEL_DATABASE_URI=http://gazebosim.org/models

to

export GAZEBO_MASTER_URI="" export GAZEBO_MODEL_DATABASE_URI=""

and

$ source /usr/share/gazebo-2.2/setup.sh

then worked fine

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-12-12 15:18:50 -0500

Seen: 32,424 times

Last updated: Jan 11 '17