Ask Your Question
0

How can I use software BRIDE in ROS FUERTE?

asked 2014-12-08 09:30:51 -0600

jav_greepo gravatar image

updated 2014-12-08 11:35:07 -0600

William gravatar image

I was trying to use BRIDE in ROS FUERTE as sain in the page http://wiki.ros.org/bride/Tutorials/C... but i cannot create a workspace in catkin because the command catkin_init_workspace generates this error:

catkin_init_workspace: command not found

Then I tried to create the workspace with rosbuild as said in http://wiki.ros.org/ROS/Tutorials/Ins... but I had another problem when i use the command:

rosws init ~/fuerte_workspace /opt/ros/fuerte

an error is displayed:

ImportError: No module named vcs_abstraction

and when i tried to install rosinstall: sudo apt-get install python-rosinstall

Another error is displayed:

Errors where encountered while processing:
python-catkin-pkg
python-rospkg
python-rosdistro
python-rosdep
python-rosinstall
edit retag flag offensive close merge delete

Comments

Yes, you should use rosbuild in ROS Fuerte. Maybe you can reference the Ros answer: link text

karen0603 gravatar imagekaren0603 ( 2014-12-08 10:40:23 -0600 )edit

I followed the link but it doesnt works for me

jav_greepo gravatar imagejav_greepo ( 2014-12-08 10:51:20 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-12-08 11:54:05 -0600

William gravatar image

Fuerte does not have catkin, that is why the catkin_init_workspace command does not work.

You will either have to update to a newer version of ROS like Hydro or Indigo or you will have to get a rosbuild version of BRIDE if it is available. I'm not sure if there are tutorials for using BRIDE with rosbuild, perhaps someone else can answer that.

I would recommend you update your ROS version though because Fuerte has been unsupported for quite some time now. I would recommend using Indigo, as it will be supported for another 4+ years.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-12-08 09:30:51 -0600

Seen: 88 times

Last updated: Dec 08 '14