Ask Your Question
0

I can't install open ni on Indigo, what Linux version should I install instead

asked 2014-11-21 08:52:34 -0500

Dynamitetalks gravatar image

What Linux version would be better to install if I want to use the Kinect? electric,fuerte or hydro or what else?

Thanks

edit retag flag offensive close merge delete

Comments

You should be able to install openni on Ubuntu 14.04 with ROS Indigo. Can you be more specific about why you can't install openni and the EXACT error message that you're encountering?

ahendrix gravatar imageahendrix ( 2014-11-22 04:41:33 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-11-22 13:43:17 -0500

ahendrix gravatar image

The openni_kinect stack is deprecated, and is no longer supported or released (as per the openni_kinect wiki page )

Instead, you should be using the openni_launch package: http://wiki.ros.org/openni_launch

sudo apt-get install ros-indigo-openni-launch
edit flag offensive delete link more
0

answered 2014-11-22 08:05:14 -0500

Dynamitetalks gravatar image

Thank you for your answer.

I've Ubuntu 14.04 installed with virtualbox and ROS Indigo.

when I try to run: sudo apt-get install ros-indigo-openni-kinect

And then I get this error: E: Unable to locate package ros-indigo-openni-kinect

I googled alot about ROS and Kinect, since Im new to it.

And came upon this:

" I had tried to get everything working on Win7 through VirtualBox, but I was never able to get the USB configuration for the Kinect to work"

http://dougsbots.blogspot.dk/2012/02/...

So I guess I've to install linux as Dual Boot.

But when I browse for ROS packages it seems that a lot of the package only works with the older ROS versions? http://stackoverflow.com/questions/25...

So would it be better to install hydro when I've to install Linux again as Dual boot.

Also is ROS Hydro compatible with the new version of Ubuntu 14.04?

edit flag offensive delete link more

Comments

ROS Hydro is not compatible with Ubuntu 14.04. Here are the packages available for ROS Indigo that you can install using apt-get http://www.ros.org/debbuild/indigo.html

Mehdi. gravatar imageMehdi. ( 2014-11-23 19:43:40 -0500 )edit

Would it be better for me to install Ubuntu 12.04.5 and ROS Hydro, if I want to make the Kinect follow me Robot, by using the open-ni-kinect packages? I didn't see the packages for the kinect in the Indigo version you linked.

Dynamitetalks gravatar imageDynamitetalks ( 2014-11-24 01:52:28 -0500 )edit

I just found the openni launch package in the indigo link, so never mind, I'll install ubuntu 14.04 and Indigo and use the open-ni launch package. Thank you to everyone,

Dynamitetalks gravatar imageDynamitetalks ( 2014-11-24 01:56:46 -0500 )edit

I had a similar issue, on ubuntu 14.04 with ros-indigo, i can't install openni_tracker node. Can you give me feedback if installing Ubuntu 12.04 with ros-hydro is resolved the problem? Or with Indigo is it possible to use openni_tracker?

berat gravatar imageberat ( 2014-12-12 14:48:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-11-21 08:52:34 -0500

Seen: 3,205 times

Last updated: Nov 22 '14