ROS Hydro-held broken packages [closed]

asked 2014-11-13 04:50:29 -0600

MarcosM gravatar image

updated 2014-11-13 05:15:19 -0600

Hi , I'm trying to install ROS Hydro on Raspberry Pi following the steps of the ROS wiki in a new installed version of Raspbian using NOOBS like it says here:

http://wiki.ros.org/ROSberryPi/Settin...

Everything is OK until I do :

sudo pip install -U rospkg sudo apt-get install python-rosdep python-rosinstall-generator build-essential

I get the next error:

Reading package lists... Done

Building dependency tree

Reading state information... Done

build-essential is already the newest version.

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies: python-rosdep : Depends: python-catkin-pkg but it is not going to be installed Depends: python-rospkg but it is not going to be installed Depends: python-rosdistro (>= 0.3.0) but it is not going to be installed python-rosinstall-generator : Depends: python-catkin-pkg (>= 0.1.28) but it is not going to be installed Depends: python-rosdistro (>= 0.3.4) but it is not going to be installed Depends: python-rospkg but it is not going to be installed E: Unable to correct problems, you have held broken packages.

How can I install it correctly or correct the error?

Thank you.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by MarcosM
close date 2014-12-03 08:08:26.301272

Comments

Have you tried manually installing the listed packages through apt-get?

hiro64 gravatar imagehiro64 ( 2014-11-13 05:53:40 -0600 )edit

Yes, and I get the same error:

the following packages have unmet dependencies: python-rospkg : Depends: python:any (>= 2.7.1-0ubuntu2) but it is not installable

I think that the error should be in python libraries.

MarcosM gravatar imageMarcosM ( 2014-11-13 05:59:27 -0600 )edit

Are you sure your computer has that version of python installed? Maybe the problem lies with your python installation then.

hiro64 gravatar imagehiro64 ( 2014-11-13 06:19:43 -0600 )edit

Yes , it has but I´m installing it on Raspberry pi.

MarcosM gravatar imageMarcosM ( 2014-11-13 06:26:04 -0600 )edit

@MarcosM I am facing the same problem..did u get the solution how to fix it ..

Mind_hunter gravatar imageMind_hunter ( 2014-12-03 07:31:04 -0600 )edit

Yes but not following any guide i have made my own steps and it works

MarcosM gravatar imageMarcosM ( 2014-12-03 08:02:34 -0600 )edit

can u please tell me how u r proceeding ....

Mind_hunter gravatar imageMind_hunter ( 2014-12-03 11:36:55 -0600 )edit

Yeah, that would be helpful for people with a similar issue

Sergio MP gravatar imageSergio MP ( 2015-02-02 04:48:45 -0600 )edit