Can't get interactive markers working in pr2_interactive_manipulation package [closed]

asked 2014-10-28 21:34:06 -0500

longlongago gravatar image

Hi all, I want to run pr2_interactive_manipulation in a real robot, but it seems pretty broken. I just used it two months ago, but I don't know why it is not work now.

see the output at after I running: roslaunch pr2_interactive_manipulation pr2_interactive_manipulation_robot.launch nav:=true

see the output at after I running: roslaunch pr2_interactive_manipulation_frontend pr2_interactive_manipulation_desktop.launch nav:=true

the rviz appears but I can not interact with the robot - no interactive markers appear anywhere.

And the fixed frame (/map) does not exist, and I manually change it to /base_link (I run the both launch file wit nav:=true).

Note that you can see the output of robot.launch, the output just cycles the following info over and over...

" Waiting for service environment_server/get_robot_state waitForService: Service [/environment_server/get_robot_state] has not been advertised, waiting... "

Can you help me fix this to get interactive markers working? Thank you very much.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by longlongago
close date 2014-10-29 09:16:13.639987


I have solved this problem, see

longlongago gravatar image longlongago  ( 2014-10-29 09:17:17 -0500 )edit