Ask Your Question
0

How to fix hydro ros in ubuntu12.04

asked 2014-10-24 22:12:35 -0500

scopus gravatar image

updated 2014-10-24 22:15:48 -0500

Hi, all, I falsely tried to update boost to be libboost1.55-dev by using PPA as this link . This caused unexpected breakdowns. Firstly, many lines with "Removing ros-hydro-xxx, Removing ros-groovy-xxx" (My OS is with two versions of ROS) came out and couldn't be stopped by "ctril+ c". Finally, a red circle with a white line in the middle of it came up in the upper-right corner of desktop of Ubuntu. Then luckily I openned "Ubuntu Software Center" and it disappear the red circle by automatically repairing some missing packages. The reason is same to this question about boost in hydro.

However, when I want to compile some packages by catkin_make, it prompted that some fundamental packages couldn't be found such as std_msgs. So I have to repair the ros-hydro. I don't know how to do. Should I re-install hydro ros by the instruction for hydro installation from ROS tutorial with uninstallation?

I have tried to uninstall hydro ros by this link, but the terminal prompted

E: Unable to locate package ros-hydro

or

E: Unable to locate package hydro

Hopefully any advice is appreciated. Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-10-25 22:28:51 -0500

tfoote gravatar image

You will need to remove the conflicting packages which you installed (and caused the uninstallation of the ros packages) Once those are removed/downgraded to the older versions you will be able to install hydro the standard way.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-24 22:12:35 -0500

Seen: 223 times

Last updated: Oct 25 '14