ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
0

Rviz Crashes (OGRE)

asked 2014-10-22 21:52:51 -0500

ROSCMBOT gravatar image

updated 2014-10-24 20:13:56 -0500

When running rviz I get the following error messages:

[ WARN] [1414015276.298139367]: OGRE EXCEPTION(7:InternalErrorException): Could not load dynamic library /usr/lib/x86_64-linux-gnu/OGRE-1.8.0/RenderSystem_GL.  System Error: /usr/lib/x86_64-linux-gnu/OGRE-1.8.0/RenderSystem_GL.so: undefined symbol: _ZN4Ogre15StringInterface17msDictionaryMutexE in DynLib::load at /home/stefania/software/ogre/OgreMain/src/OgreDynLib.cpp (line 93)

terminate called after throwing an instance of 'Ogre::InternalErrorException'
  what():  OGRE EXCEPTION(7:InternalErrorException): Could not load dynamic library /usr/lib/x86_64-linux-gnu/OGRE-1.8.0/RenderSystem_GL.  System Error: /usr/lib/x86_64-linux-gnu/OGRE-1.8.0/RenderSystem_GL.so: undefined symbol: _ZN4Ogre15StringInterface17msDictionaryMutexE in DynLib::load at /home/stefania/software/ogre/OgreMain/src/OgreDynLib.cpp (line 93)
Aborted (core dumped)

I'm running on Ubuntu 14.04 and ROS Indigo.

My graphics card info:

VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09) (prog-if 00 [VGA controller])

UPDATE 1

Running rviz tries to compile against OGRE 1.8.1, and then gives the error messages above

[ INFO] [1414078694.030851551]: compiled against OGRE version 1.8.1 (Byatis)

and on this path

 /usr/lib/x86_64-linux-gnu/

I have three versions of OGRE

OGRE-1.8.0/ OGRE-1.8.1/ OGRE-1.9.0/

UPDATE 2

So I removed all versions of OGRE.

First installed libogre-1.9-dev. For some reason, rviz was also removed from my machine. I tried to install it again, and it says:

The following packages have unmet dependencies:
 ros-indigo-rviz : Depends: libogre-1.8-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

So I Installed libogre-1.8-dev and then installed rviz , but again getting the error messages above while running rviz and it crashes

UPDATE 3

Ok I uninstalled OGRE (and rviz automatically)

  sudo apt-get remove libogre-1.8.0 libogre-1.8.0-dbg libogre-1.8-dev

I tried to install rviz and this time didn't give any dependency error and automatically installed ogre too

  sudo apt-get install ros-indigo-rviz

Just in case I also ran this command:

  sudo apt-get install libogre-1.8.0 libogre-1.8.0-dbg libogre-1.8-dev

Currently in /usr/lib/x86_64-linux-gnu/ I have only these ogre folders:

OGRE-1.8.0/ OGRE-1.8.1/
edit retag flag offensive close merge delete

Comments

Do you have a custom version of OGRE installed? From the library path, it looks like it's trying to use a custom version of OGRE rather than the system default.

ahendrix gravatar imageahendrix ( 2014-10-22 23:30:42 -0500 )edit

Not actually, it's default installation of ubuntu 14.04

ROSCMBOT gravatar imageROSCMBOT ( 2014-10-22 23:50:19 -0500 )edit
1

Are you sure? /home/stefania/software/ogre/OgreMain/src/OgreDynLib.cpp seems to suggest otherwise.

gvdhoorn gravatar imagegvdhoorn ( 2014-10-23 10:46:54 -0500 )edit

This is interesting! /home/Stefania is not on my machine!

ROSCMBOT gravatar imageROSCMBOT ( 2014-10-23 13:18:17 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-11-02 19:11:36 -0500

ROSCMBOT gravatar image

Webots Software was the reason that rviz was crashing on my machine. After I uninstalled webots, rviz again is working fine.

edit flag offensive delete link more
0

answered 2014-10-23 14:46:15 -0500

ahendrix gravatar image

updated 2014-10-24 03:08:54 -0500

The version of OGRE that I have on my 14.04 machine has this build path: /build/buildd/ogre-1.8-1.8.1+dfsg/OgreMain/src/OgreDynLib.cpp. Your version is different for some reason, and seems to be missing symbols that are required internally.

I would investigate how you installed OGRE, and maybe try removing and reinstalling it through apt.

EDIT:

It's odd that APT won't let you install rviz because of some issue with the ogre dependency, and yet somehow you can install OGRE manually and it's OK? That sounds fishy. Please list the exact commands you use to install OGRE (1.8) and rviz.

(It is possible that you don't have the appropriate universe and multiverse repositories enabled?)

edit flag offensive delete link more

Comments

Thanks. Updated my Question

ROSCMBOT gravatar imageROSCMBOT ( 2014-10-23 15:23:07 -0500 )edit

This doesn't appear to be a problem with RVIZ, it looks like an ABI mismatch that is internal to OGRE. Have you tried reinstalling OGRE through apt?

ahendrix gravatar imageahendrix ( 2014-10-23 15:27:01 -0500 )edit

universe and multiverse repositories are both enabled according to this file: /etc/apt/sources.list

ROSCMBOT gravatar imageROSCMBOT ( 2014-10-24 19:59:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-22 21:52:51 -0500

Seen: 1,837 times

Last updated: Nov 02 '14