RGBDSLAMv2 need advice for better reconstruction using handheld device

asked 2014-10-17 15:06:56 -0500

Swagatika gravatar image

I just installed RGBDSLAMv2 on Ubuntu12.04 and started using it for creating 3D model of object I am using. However, I get blurred and inconsistent result. The snapshot is is the following link (somehow, I can't upload image to the question):

https://www.dropbox.com/s/z6tsii1gi4m...

I have set the following parameters in the launch file:

<!-- Input data settings-->
<param name="config/topic_image_mono"              value="/camera/rgb/image_raw"/>
<param name="config/topic_image_depth"             value="/camera/depth_registered/image_raw"/>
<param name="config/topic_points"                  value="/camera/depth_registered/points"/> <!--if empty, point cloud will be reconstructed from image and depth -->

<param name="config/feature_detector_type"         value="SIFT"/><!-- also available: SIFT, SURF, GFTT (good features to track), ORB. -->
<param name="config/feature_extractor_type"        value="SIFT"/><!-- also available: SIFT, SURF, SURF128 (extended SURF), ORB. -->
<param name="config/nn_distance_ratio"             value="0.8"/> <!-- Feature correspondence is valid if distance to nearest neighbour is smaller than this parameter times the distance to the 2nd neighbour -->
<param name="config/max_keypoints"                 value="1000"/><!-- Extract no more than this many keypoints (not honored by SIFTGPU)-->
<param name="config/ransac_iterations"             value="200"/>
<param name="config/cloud_creation_skip_step"      value="4"/><!-- subsample the images' pixels (in both, width and height), when creating the cloud -->
<param name="config/data_skip_step"                value="1"/><!-- subsample the image frames (in time) -->

<param name="config/voxelfilter_size"              value="0.01"/><!-- downsample the input point cloud -->
<param name="config/use_icp"                       value="true"/><!-- downsample the input point cloud -->
<param name="config/maximum_depth"                 value="1.5"/><!-- save the point clouds in the this range only -->

I do not have any clue what is going wrong. If there are specific parameters I need to adjust or any setting I must do in order to get the correct reconstruction, please let me know..

Thanks.

edit retag flag offensive close merge delete