Ask Your Question

Command not found roscd, rosnode, etc.

asked 2014-10-15 12:45:31 -0500

FelipC gravatar image

I follow this tutorial to get ROS in my mac: I followed it and seems that everything is working perfect, but when I try roscd or rosnode it says command not found. Does anybody know how to solve it?

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted

answered 2014-10-15 15:29:53 -0500

William gravatar image

@FelipC can you verify that you have rosbash in your workspace which you installed? This package provides the bash functions which you seem to be missing. You can look for it in the src/ros_comm folder.

edit flag offensive delete link more

answered 2016-01-07 08:32:36 -0500

Sandeep gravatar image

Try installing ros-<distro>-rosbash package! This should resolve your issue.

edit flag offensive delete link more


it worked,thanks a lot

spri gravatar image spri  ( 2016-10-16 23:48:04 -0500 )edit

This worked for me. (ros-indigo)

sunilsulania9192 gravatar image sunilsulania9192  ( 2017-09-06 04:22:11 -0500 )edit

answered 2014-10-15 13:14:18 -0500

William gravatar image

Did you source the setup.bash in the resulting install_isolated folder?

You have to make sure to source the setup.bash rather than the otherwise you will not get command line tools which are actually bash functions, like roscd.

edit flag offensive delete link more


Yes, I did this: source /opt/local/setup.bash And other commands are working like roscore...

FelipC gravatar image FelipC  ( 2014-10-15 13:32:34 -0500 )edit

Did you also add it to your .bashrc file? In my case it is: source /opt/ros/hydro/setup.bash (but your's may be right for you) You find the .bashrc in your "personal folder" (i have the german version). There you press CTRL+H. This change will source the setup.bash after every restart.

RosBort gravatar image RosBort  ( 2014-10-15 14:24:49 -0500 )edit

I did it right now but still not working...

FelipC gravatar image FelipC  ( 2014-10-15 14:36:41 -0500 )edit

answered 2020-11-05 03:08:45 -0500

In my case, I just run this following code:

sudo apt install ros-noetic-desktop-full

source /opt/ros/noetic/setup.bash

Try it!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2014-10-15 12:31:03 -0500

Seen: 12,692 times

Last updated: Oct 15 '14