Ask Your Question
0

actionlib fibonacci_server doesn't move at all

asked 2014-10-14 12:08:15 -0500

W_Kohei gravatar image

updated 2014-11-07 11:05:03 -0500

Hi, I am a beginner to use ROS. (ubuntu 12.04, and ROS distribution is hydro. but I have installed both groovy and hydro.)

Now, I finished Beginner Level of Core ROS Tutorials and then tried to do actionlib_tutorials.

I only followed the instructions in this URL ( http://wiki.ros.org/actionlib_tutoria... ),

Start a roscore in a new terminal

$ roscore

Until the section above, I did well.

But in the next section below, I failed.


And then run the action server:

$ rosrun learning_actionlib

fibonacci_server You will see something similar to:

[ INFO] 1250790662.410962000: Started node [/fibonacci], pid [29267], bound on [aqy], xmlrpc port [39746], tcprosport [49573], logging to [~/ros/ros/log/fibonacci_29267.log], using [real] time To check that your action is running properly list topics being published:


If I command the sentence below,

$ rosrun learning_actionlib fibonacci_server

there was no response.

I would like to know why.

If I run the command

$rostopic list -v ,I got these messages.

Published topics: * /fibonacci/feedback [learning_actionlib/FibonacciActionFeedback] 1 publisher * /rosout [rosgraph_msgs/Log] 1 publisher * /rosout_agg [rosgraph_msgs/Log] 1 publisher * /fibonacci/status [actionlib_msgs/GoalStatusArray] 1 publisher * /fibonacci/result [learning_actionlib/FibonacciActionResult] 1 publisher

Subscribed topics: * /fibonacci/goal [learning_actionlib/FibonacciActionGoal] 1 subscriber * /fibonacci/cancel [actionlib_msgs/GoalID] 1 subscriber * /rosout [rosgraph_msgs/Log] 1 subscriber

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-10-15 01:55:31 -0500

Rabe gravatar image

Might be that it is just some logger settings.

To check if the node is running, run the following command rosnode list and see if your actionserver pops up. In that casse, you can try to continue with the tutorial and check if the server answers.

edit flag offensive delete link more

Comments

Thank you for answering my question and I am sorry for my late reply.

If I run the command "rosnode list", /fibonacci /rosout only these words were displayed. It seems that actionserver doesn't work well....

W_Kohei gravatar image W_Kohei  ( 2014-11-07 10:49:12 -0500 )edit

Just after fibonacci_server and fibonaccci_client are started, I run that command then I could get these messages" /fibonacci /rosout /test_fibonacci"

W_Kohei gravatar image W_Kohei  ( 2014-11-07 11:02:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-10-14 12:08:15 -0500

Seen: 202 times

Last updated: Nov 07 '14