Ask Your Question
0

Messed up workspace - Where to start looking? [closed]

asked 2014-10-14 10:31:12 -0500

Rabe gravatar image

Hello together,

I have the follwing problem: I have the package ar_track_alvar installed via binary packages. Also I have my own catkin-workspace.

Now, when I first source /opt/ros/hydro/setup.bash followed by my_workspace/devel/setup.bash, I see all the included launch files, but only the createMaker-Node. All the other nodes wont autocomplete and when launch-files rely on them, they can't be found.

But when I source opt/ros/hydro/setup.bash again, everything works as expected.

What might be the issue? Obviously something is wrong in my workspace, but I don't know where to begin looking.


Additional information: In both cases I can autocomplete the package name, e.g. in roscd ar_tr<tab> to ar_track_alvar. Also in both cases I land in the same directory: /opt/ros/hydro/share/ar_track_alvar

Thanks in advance,

Rabe

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Rabe
close date 2014-10-14 10:49:46.715847

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-10-14 10:42:49 -0500

dornhege gravatar image

First: Sourcing order does NOT matter. Whatever you source last should be active. So probably your workspace isn't build on hydro.

Under the assumption that you'd like to overlay the catkin workspace using hydro the following should fix that:

  • Remove all build/devel/install dirs from the workspace
  • source /opt/ros/hydro/setup.bash
  • catkin_make

From now on: source my_workspace/devel/setup.bash

edit flag offensive delete link more

Comments

Thanks, removing those 2 folders should have been the first obvious step. Solved my problem.

Rabe gravatar imageRabe ( 2014-10-14 10:49:25 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-10-14 10:31:12 -0500

Seen: 51 times

Last updated: Oct 14 '14