Ask Your Question
0

openni_tracker or openni2_tracker for ROS indigo

asked 2014-10-14 09:51:58 -0600

yoo00 gravatar image

updated 2014-10-14 10:28:22 -0600

Hi all,

I am currently using ASUS Xtion on 64 bit ubuntu 14.04 and ROS indigo, and trying to implement skeleton tracking using openni and openni_tracker. The version of my Xtion is old one, so mine works for both openni_launch and openni2_launch. I have OpenNI 1.5.4.0, OpenNI 2.2.0, NITE 1.5.2.23, and NITE 2.2. I've been using them to get either openni_tracker or openni2_tracker working, but I wasn't able to. I literally tried lots of combinations that I can come up for this but I don't get it why.

Since there is not much information on openni, is there anyone who has succeeded in implementing either openni_tracker or openni2_tracker on ROS indigo? I guess kinect or Xtion doesn't matter for this problem. Any advice or experience would be really appreciable. Thanks in advance!

--edit If you see link text, it mentions the possibility of removing NITE library from openni_tracker. Do you guys think openni_tracker(or openni2_tracker) without NITE library can be achievable?

edit retag flag offensive close merge delete

Comments

so, which one is the installer for Nite2? i have problem for library and path Nite2 in ros package.

adelleodel gravatar imageadelleodel ( 2015-10-29 08:14:52 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-02-05 10:06:29 -0600

lazy gravatar image

have you had any success with this? I am trying to make the openni_tracker work on ROS indigo with Kinect. I installed the package from the source and it compiled. When I run it, the Kinect detects the user and the Psi pose, but it doesn't publish anything on the /tf topic, actually there is no /tf topic.

edit flag offensive delete link more

Comments

i also want to use openni_tracker with ros indigo... i tried downloading openni_tracker-hydro package from github and put in my workspace.... i also installed NITE package... but it is not working... while running: rosrun openni_tracker openni_tracker, it says it can't create any node of req. type

Arpitsoni gravatar imageArpitsoni ( 2017-01-06 00:29:29 -0600 )edit
0

answered 2015-09-30 07:09:16 -0600

Gloria@HK gravatar image

Hi, I have just tested this packages. Actually just download the openni_tracker package from the git and catkin_make it in my workspace.

Also install Nite v 1.5.2.23 with the instruction of the Git page.

And

roslaunch openni_launch openni.launch

rosrun openni_tracker openni_tracker

Luckily it succeeds!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-10-14 09:51:58 -0600

Seen: 2,695 times

Last updated: Sep 30 '15