Ask Your Question
0

roslaunch doesn't work

asked 2014-09-22 13:20:31 -0500

DanielLSM gravatar image

In the roslaunch tutorial, running turtlemimic.launch doesn't work, i get:

[turtlemimic.launch] is neither a launch file in package [beginner_tutorial] nor is [beginner_tutorial] a launch file name

Can anyone help me?

Thanks

edit retag flag offensive close merge delete

Comments

can you post the command you are using; did you save the turtlemimic.launch file in launch folder ?

bvbdort gravatar imagebvbdort ( 2014-09-22 14:21:57 -0500 )edit

screenshot of the problem

Have roscore running, made the source of setup.bash, beginner_tutorials is recognized as a package and roslaunch gives that error, any help?

DanielLSM gravatar imageDanielLSM ( 2014-09-22 15:47:30 -0500 )edit

screenshot of the problem

Have roscore running, made the source of setup.bash, beginner_tutorials is recognized as a package and roslaunch gives that error, any help?

DanielLSM gravatar imageDanielLSM ( 2014-09-22 15:47:49 -0500 )edit

see my edit above

Andromeda gravatar imageAndromeda ( 2014-09-22 16:07:54 -0500 )edit

for those who have this problem ([beginner_tutorials] is not a package or launch file name) please follow this tutorial: http://wiki.ros.org/catkin/Tutorials/...

Amer Al-Radaideh gravatar imageAmer Al-Radaideh ( 2017-01-28 01:31:09 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2014-09-22 16:48:53 -0500

DanielLSM gravatar image

Thank you for answers, apparently turtlemimic.launch was not a .launch file ... fixed^^

edit flag offensive delete link more
1

answered 2014-09-22 14:35:12 -0500

Andromeda gravatar image

updated 2014-09-22 16:06:33 -0500

Maybe it could be a stupid question, but did you created the folder with catkin_create_pkg before? As explained in the tutorial, it is supposed you created that folder with that command. If you used mkdir or something like that, ros will never recongize the right folder.

And don't forget the source devel/setup.bash if you didn t automate the process after building your code.

EDIT: It didn 't recognize the package in your catkin environment (your screenshot). Please be sure that a

CMakeLists.txt

is in your beginner_tutorials package and is correctly written. Then go into your workspace:

daniel@daniel-G74Sx:~$ cd catkin_ws

and run the command catkin_make again. Later on source the file devel/setup again.

It semms to me you are trying to launch the launch file from your home directory and not from the catkin workspace

edit flag offensive delete link more

Comments

screenshot of the problem

Yes i made the tutorials line by line without a single mistake and dind't failed until this step. Have roscore running, made the source of setup.bash, beginner_tutorials is recognized as a package and roslaunch gives that error, any help?

DanielLSM gravatar imageDanielLSM ( 2014-09-22 15:47:40 -0500 )edit

problem_2

In this screenshot i show that i execute catkin_make without problems, show that beginner tutorials is recognized as a package and that roslaunch still doesn't work.....

DanielLSM gravatar imageDanielLSM ( 2014-09-22 16:20:14 -0500 )edit
0

answered 2014-09-22 15:50:48 -0500

cmeaclem gravatar image

You might need to change the permissions with sudo chmod a+x <filename> I also echo @Andromeda that you might need to source devel/setup.bash

If you try using roslaunch and the tab autocompletion but it doesn't work, i find it is generally because i haven't sourced setup.bash.

edit flag offensive delete link more

Comments

setup.bash is sourced and is even sourced in my ~/.bashrc, the autocompletion works with roslaunch ^^

DanielLSM gravatar imageDanielLSM ( 2014-09-22 15:58:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-22 13:20:31 -0500

Seen: 2,191 times

Last updated: Sep 22 '14