ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
1

How to tackle 'symbol lookup error' and 'ros::InvalidNameException' on Odroid

asked 2014-09-12 03:27:10 -0500

rookie gravatar image

I am trying to run camera calibration on my Odroid U3 running Lubuntu 13.04. I ran the following command :

rosrun uvc_camera uvc_camera_node width:=640 height:=480 frame:=camera device:=/dev/video0

after which a i got an error :

terminate called after throwing an instance of 'ros::InvalidNameException' what(): Character [4] is not valid as the first character in Graph Resource Name [480]. Valid characters are a-z, A-Z, / and in some cases ~. Aborted (core dumped)

running the same command without specifying height and width, i get the following error:

/opt/ros/hydro/lib/uvc_camera/uvc_camera_node: symbol lookup error: /opt/ros/hydro/lib/libimage_transport.so: undefined symbol: _ZN3ros7package10getPluginsERKSsS2_RSt6vectorISsSaISsEEb

How do I overcome this problem??

I have followed earlier tutorials successfully and have sourced required files.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-09-12 08:08:24 -0500

ahendrix gravatar image

Two issues:

(1) It doesn't look like you're supplying the parameters to the uvc_camera node properly. Private parameters should be prefixed with an _. Try:

rosrun uvc_camera uvc_camera_node _width:=640 _height:=480 _frame:=camera _device:=/dev/video0

(2) It looks like you've picked up the ABI breakage in roslib. Try upgrading everything to the latest version:

sudo apt-get update
sudo apt-get upgrade

If apt says that there are "held packages" or "packages not upgraded" then do a sudo apt-get dist-upgrade as well.

edit flag offensive delete link more

Comments

Thanks! the first step didn't work..i tried apt-get update but i got an error: Failed to fetch http://winswitch.org/dists/precise/Re... Unable to find expected entry 'main/binary-armhf/Packages' in Release file) Wont lubuntu upgrade to a higher version and screw up hydro with apt-get upgrade?

rookie gravatar imagerookie ( 2014-09-12 09:06:00 -0500 )edit

It looks like you have a winswitch repo configured, but it doesn't support armhf. You should probably remove that from your apt sources and try again.

apt-get upgrade and dist-upgrade both install new versions of packages; they don't upgrade to a new version of Ubuntu.

ahendrix gravatar imageahendrix ( 2014-09-12 09:28:12 -0500 )edit

Thanks, will try this out !

rookie gravatar imagerookie ( 2014-09-12 12:58:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-12 03:27:10 -0500

Seen: 1,072 times

Last updated: Sep 12 '14