ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
0

Eclipse IDE Run Configurations Environment Variables [closed]

asked 2014-09-10 06:52:50 -0500

ish45 gravatar image

updated 2014-09-10 07:44:04 -0500

bvbdort gravatar image

I am configuring Eclipse to enable autocompletion for programming using rospy. So, can anyone please provide the Paths in Eclipse for the following Variables :

1) PATH 2) PYTHONPATH 3) ROS_MASTER_URI 4) ROS_PACKAGE_PATH 5) ROS_ROOT

I have followed all the steps from the tutorial here. http://wiki.ros.org/IDEs

But, when I run the test.py file, it gives an error saying "No Module named rospy"

I think, I am not setting the environment variables correctly. Hence, Please someone provide the environment variables you use so that I can correct the mistake if any.

Also, if somebody of you have any other suggestions, I would be pleased to know

Thanks,

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by ish45
close date 2014-09-12 02:38:30.379428

3 Answers

Sort by ยป oldest newest most voted
2

answered 2014-09-11 00:43:55 -0500

BennyRe gravatar image

The first paragraph of the wiki page you linked answers your question.

The easiest way to get the environment variables correctly inside eclipse is to run eclipse from a shell shell that sources your setup.bash.

edit flag offensive delete link more
1

answered 2014-09-10 07:11:55 -0500

ahendrix gravatar image

The settings for these will vary wildly based on your system, which version of ROS you're running, and possibly your workspace.

It may be better to extract them from your system by sourcing the setup.sh for your workspace and then inspecting the resulting environment.

edit flag offensive delete link more

Comments

I am using ROS Hydro on Ubuntu 12.04.

ish45 gravatar imageish45 ( 2014-09-10 09:18:00 -0500 )edit
0

answered 2014-09-11 09:05:38 -0500

ish45 gravatar image

Thanks to all. It is working now. I changed the workspace of eclipse to be the catkin workspace and followed the tutorial here http://u.cs.biu.ac.il/~yehoshr1/89-68... which is an excellent tutorial and solved my problem. Thanks to all.

edit flag offensive delete link more

Comments

If your solution works mark it as correct, please.

BennyRe gravatar imageBennyRe ( 2014-09-12 00:09:08 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-09-10 06:52:50 -0500

Seen: 422 times

Last updated: Sep 11 '14