Ask Your Question
2

Is there any IDE which offers Auto Complete Features for rospy library?

asked 2014-09-08 07:29:09 -0600

ish45 gravatar image

Hi.

I want to know whether Eclipse or any other IDE offers autocomplete features for rospy library. For example if we write "rospy." the the IDE should automatically suggest the different functions that we can use.

Does any IDE offer this feature?

Kindly, help me.

Thanks

edit retag flag offensive close merge delete

Comments

Lately, I've been having great success using jedi for all Python completions, including rospy, in emacs.

jarvisschultz gravatar imagejarvisschultz ( 2014-09-08 08:34:47 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-09-08 08:01:45 -0600

Airuno2L gravatar image

With a little bit of setup, which is described here, Eclipse can do this very well.

edit flag offensive delete link more

Comments

Thanks. I have tried to do from this tutorial, but I am still unable to get auto completion and other features. Is it possible for you to help me in any way??

ish45 gravatar imageish45 ( 2014-09-09 20:04:09 -0600 )edit

Are you receiving any errors throughout the process? Or did you go through the steps without problem and it is just not working?

Airuno2L gravatar imageAiruno2L ( 2014-09-10 07:34:18 -0600 )edit

I completed all the steps and also imported the project into eclipse and also added the Environment Variables as mentioned above. But, when do coding and write "import rospy" and try to run it says that rospy module not found. Could you suggest what could be the possible solution?

ish45 gravatar imageish45 ( 2014-09-10 09:25:21 -0600 )edit

Are you starting eclipse by clicking on the icon, or launching it from the command line? If starting from the icon, try launching from command line. I'm assuming you've configured your ROS environment the way described here.

Airuno2L gravatar imageAiruno2L ( 2014-09-10 09:30:56 -0600 )edit

And that you have source /opt/ros/hydro/setup.bash in your /.bashrc

Airuno2L gravatar imageAiruno2L ( 2014-09-10 09:31:48 -0600 )edit

Yes, I have tried launching it both from command line and from the icon. I have also configured my ros environment. But still it is not able to resolve the imports. Thanks for the help. Would Emacs be better option ?

ish45 gravatar imageish45 ( 2014-09-10 10:22:38 -0600 )edit
1

Thanks. It is working now. I changed the workspace of eclipse to be the catkin workspace and followed the tutorial here http://u.cs.biu.ac.il/~yehoshr1/89-68... which is an excellent tutorial and solved my problem. Thanks to all.

ish45 gravatar imageish45 ( 2014-09-11 09:04:37 -0600 )edit

Excellent find. Glad you got it up and running.

Airuno2L gravatar imageAiruno2L ( 2014-09-11 09:50:01 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-08 07:29:09 -0600

Seen: 567 times

Last updated: Sep 08 '14