Ask Your Question
0

rosdep update is requested repeatedly

asked 2014-09-08 02:26:39 -0500

gus484 gravatar image

updated 2014-09-10 04:27:05 -0500

Hi,

I followed the tutorial Installing on Raspberry PI/Raspbian from source and have a problem at point 5.6. When I try the command "sudo rosdep check --from-paths src --ignore-src --rosdistro groovy" I get the error "ERROR: your rosdep installation has not been initialized yet. Please run: rosdep update". The command "rosdep update" has no effect and error message comes again. I run "sudo rosdep init" before.

Thanks for help.

UPDATE 1:

rosdep update

Hit https://github.com/ros/rosdistro/raw/master/rosdep/osx-homebrew.yaml
Hit https://github.com/ros/rosdistro/raw/master/rosdep/base.yaml
Hit https://github.com/ros/rosdistro/raw/master/rosdep/python.yaml
Hit https://github.com/ros/rosdistro/raw/master/rosdep/ruby.yaml
Hit https://github.com/ros/rosdistro/raw/master/releases/fuerte.yaml
Query rosdistro index https://raw.github.com/ros/rosdistro/master/index.yaml
Add distro "groovy"
Add distro "hydro"
Add distro "indigo"
updated cache in /root/.ros/rosdep/sources.cache

With the sudo command (sudo rosdep update) it works and I could run after some fixes in the file "gbpdistro_support.py" the following command:

sudo rosdep check --from-paths src --ignore-src --rosdistro groovy --os=debian:wheezy

but got another problem:

System dependencies have not been satisified: apt ros-groovy-urdf

sudo apt-get install ros-groovy-urdf

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-groovy-urdf : Depends: ros-groovy-collada-parser but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

sudo apt-get install ros-groovy-collada-parser

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-groovy-collada-parser : Depends: collada-dom2.4-dp-base (>= 2.4.0.16+rpi1) but it is not installable
E: Unable to correct problems, you have held broken packages.

I have built and installed the collada package successfully how it was described in point 5.5.

UPDATE 2:

The result is not much different.

sudo rosdep install --from-paths src --ignore-src --rosdistro groovy -yr --os=debian:wheezy

executing command [sudo apt-get install -y ros-groovy-urdf]
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-groovy-urdf : Depends ...
(more)
edit retag flag offensive close merge delete

Comments

Please show your commands and the console output from running them.

tfoote gravatar image tfoote  ( 2014-09-08 17:06:46 -0500 )edit

To install system dependencies use rosdep install instead of check.

BennyRe gravatar image BennyRe  ( 2014-09-09 05:11:40 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-09-09 16:32:39 -0500

tfoote gravatar image

updated 2014-09-23 03:09:55 -0500

WIth your manually installation of collada-dom you'll want to tell rosdep to skip that key as you've manually installed it. Try using "--skip-keys=collada-dom" in your rosdep install invocation.

Edit re update 3: Unless you're very lucky, you cannot install binaries on top of your custom compiled version of collada-dom. Any package which builds on top of that you'll want to build from source and not install the binary debian packages.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-08 02:26:39 -0500

Seen: 493 times

Last updated: Sep 23 '14