Ask Your Question
2

Error in catkin_ws

asked 2014-08-24 20:23:30 -0600

Hello Everyone!!

Tutorial: http://wiki.ros.org/nao/Installation/remote

When use:

cd ~/catkin_ws/
wstool set humanoid_msgs --git https://github.com/ahornung/humanoid_msgs

Get this error:

ERROR in config: Command requires a target workspace.

I created the catkin_ws according to http://wiki.ros.org/catkin/Tutorials/create_a_workspace

A lot of thanks!!

edit retag flag offensive close merge delete

Comments

Did you make sure that the command source ~/catkin_ws/devel/setup.bash is executed every time you open a new terminal?

You should add source ~/catkin_ws/devel/setup.bash to the file ~/.bashrc

Martin Peris gravatar imageMartin Peris ( 2014-08-24 21:54:41 -0600 )edit
1

A lot of Thanks!!!

Do you know what the folder I have to keep "humanoid_msgs"

Is in ~/catkin_ws/src?

vncntmh gravatar imagevncntmh ( 2014-08-26 07:44:52 -0600 )edit

Continue the same problem:

~/catkin_ws/src$ wstool set humanoid_msgs --git https://github.com/ahornung/humanoid_msgs
ERROR in config: Command requires a target workspace.
vncntmh gravatar imagevncntmh ( 2014-08-26 08:00:04 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
5

answered 2014-08-25 01:09:40 -0600

gvdhoorn gravatar image

updated 2014-08-27 01:38:19 -0600

ERROR in config: Command requires a target workspace.

In addition to the comment of @Martin Peris: afaik the cwd needs to be the directory containing the .rosinstall file. Alternatively, you need to provide the -t WORKSPACE or --target-workspace=WORKSPACE argument to point wstool to the proper directory.

For your particular situation (with the cwd being ~/catking_ws), this would be:

wstool set --target-workspace=src humanoid_msgs --git https://github.com/ahornung/humanoid_msgs

Edit:

@vncntmh wrote:

Get this error:

ERROR in config: /home/vincent/src has no workspace configuration file '.rosinstall'

Ah, so your source space hasn't been initialised by wstool. First do:

wstool init ~/catking_ws/src

then the wstool set .. should succeed.

edit flag offensive delete link more

Comments

Used:

 wstool set ~/catkin_ws/src humanoid_msgs --git https://github.com/ahornung/humanoid_msgs
 Error: Too many arguments.
 wstool set [localname] [SCM-URI]?  [--(svn|hg|git|bzr)] [--version=VERSION]]
vncntmh gravatar imagevncntmh ( 2014-08-26 07:58:02 -0600 )edit

Your commandline doesn't make sense: you're missing the --target-workspace argument.

gvdhoorn gravatar imagegvdhoorn ( 2014-08-26 08:38:12 -0600 )edit

So, How is?

vncntmh gravatar imagevncntmh ( 2014-08-26 09:09:40 -0600 )edit

Does the example command line from my initial answer not work for you?

gvdhoorn gravatar imagegvdhoorn ( 2014-08-26 09:27:46 -0600 )edit

Get this error:

ERROR in config: /home/vincent/src has no workspace configuration file '.rosinstall'
vncntmh gravatar imagevncntmh ( 2014-08-26 16:36:15 -0600 )edit
wstool set ~/catkin_ws/src humanoid_msgs --git https://github.com/ahornung/humanoid_msgs

ERROR in config: Command requires a target workspace.

Same problem.

btaher20 gravatar imagebtaher20 ( 2016-02-16 08:59:30 -0600 )edit

You're also missing the -t option. Also: make sure that ~/catkin_ws/src already contains a .rosinstall file, or it won't work.

gvdhoorn gravatar imagegvdhoorn ( 2016-02-16 09:16:56 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-24 20:23:30 -0600

Seen: 5,022 times

Last updated: Feb 16 '16