Ask Your Question
0

UDOO sicktoolbox

asked 2014-08-21 23:03:26 -0600

asusrog gravatar image

Hello, i am running ubuntu 13.04 on UDOO and ros hydro. I have been trying to install sicktoolbox_wrapper on udoo since yesterday by following the "using sicklms" guide but unfortunately i get stuck at the first step, when i try to do "rosdep update" i get an error which says "AssertionError: unable to handle 'index' format version '2' please update rosdistro. But when i try to update it tells me "python-rosdistro is already the newest version".Any help would be greatly appreciated. Thank you.

edit retag flag offensive close merge delete

Comments

Which apt repository are you using?

ahendrix gravatar imageahendrix ( 2014-08-22 00:07:13 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-08-22 00:22:02 -0600

ahendrix gravatar image

updated 2014-08-22 00:26:45 -0600

According to the ARM Hydro status page, the sick packages should be installable through apt (they're currently marked as outdated because I'm working on updated builds).

Try:

sudo apt-get install ros-hydro-sicktoolbox-wrapper

UPDATE

The UDDO installation instructions were using a very out-of-date ARM repository (I've updated them now); please update your /etc/apt/sources.list.d/ros-latest.list to:

deb http://packages.namniart.com/repos/ros raring main
edit flag offensive delete link more

Comments

yes i was using the old repository.. I have successfully installed the package now.. but when i try to run it.. "rosrun sicktoolbox_wrapper sicklms" nothing happens, the terminal freezes..

asusrog gravatar imageasusrog ( 2014-08-23 04:22:00 -0600 )edit

For some nodes, no output and no prompt is normal. I don't have much experience with the sick driver, so I'm not sure what it's supposed to do. Do you have an x86 machine that you can compare it with?

ahendrix gravatar imageahendrix ( 2014-08-23 13:44:19 -0600 )edit

yes actually i use it sometimes on my laptop as well and it works right away.. Even when the sensor isnt connected.. i get this error- Unable to open serial port

asusrog gravatar imageasusrog ( 2014-08-24 07:43:46 -0600 )edit

I guess it is because m unable to see my sensor as a /dev/ttyACM0 or /dev/ttyUSB0 device on UDOO.. I've tried compiling a kernel with cdc_acm module enabled but with no luck.. It still doesnt do anything.. :(

asusrog gravatar imageasusrog ( 2014-08-24 07:47:53 -0600 )edit

It's quite possible that the sick driver doesn't run well on ARM; you're probably one of the first people to try it. You should open a ticket and work with the package maintainers to troubleshoot your problem.

ahendrix gravatar imageahendrix ( 2014-08-24 11:57:39 -0600 )edit

I just connected my usb memory stick, i can access the contents. It is being mounted properly but UDOO is not creating a device node for it as well. Could it be a kernel bug or something? or m i missing something here.

asusrog gravatar imageasusrog ( 2014-08-24 23:18:44 -0600 )edit

M sorry, i know this is not the place for such questions but i figured you could help me with this. i've tried most of the relevant forums but no replies whatsoever. The kernel version is 3.0.35

asusrog gravatar imageasusrog ( 2014-08-24 23:19:46 -0600 )edit

The issue on sicktoolbox_wrapper is https://github.com/ros-drivers/sickto... ; let's keep the discussion there now that we know this is a bug.

ahendrix gravatar imageahendrix ( 2014-08-25 01:04:10 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-21 23:03:26 -0600

Seen: 254 times

Last updated: Aug 22 '14