Ask Your Question
0

rqt_graph problem

asked 2014-08-20 07:41:41 -0500

EranK gravatar image

I am trying to launch rqt_graph and receive (consistently) the following message:

rqt_graph: Fatal IO error: client killed

I am using ROS hydro on Ubuntu 12.04.5 via ssh.

Any idea what could be the problem?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-08-20 09:27:43 -0500

Murilo F. M. gravatar image

If you are accessing the machine running ROS over ssh and you want to open rqt_graph on the remote machine, X11 forwarding is not enabled by default. In order to allow graphical interfaces (X11) through ssh, you should run:

$ ssh user@machine-ip -Y

You could also use:

$ ssh user@machine-ip -X

for untrusted clients.

A nice explanation of the difference between -Yand -X can be found here.

I hope I did not misunderstand your question.

edit flag offensive delete link more

Comments

I am using F-Secure SSH Client application on a windows 8 platform to connect to the Ubuntu machine so I do not use a command line to launch ssh. Looking at the settings of the terminals that I open, the Tunnel X11 Connections are enabled but the problem remains. In addition, I use xming as the display server on the windows platform. Do you have experience with running rqt via F-Secure SSH client?

EranK gravatar image EranK  ( 2014-08-20 10:36:12 -0500 )edit

And in addition, I tried using ssh2 (the trusted machine uses +X flag) and received same response. Other graphical applications (gedit, turtlesim, emacs) work fine... (BTW - all rqt applications give the same "Fatal IO error")

EranK gravatar image EranK  ( 2014-08-20 11:08:39 -0500 )edit
1

I think you're having generic problems with your xforwarding. I'd suggest that you debug that on other forums and come back here if you can get basic programs like xeyes working but not rqt_plot. Note several ROS programs use opengl which is not well supported over x forwarding.

tfoote gravatar image tfoote  ( 2014-08-20 12:09:37 -0500 )edit

'xeyes' as well as various other graphic (X based) applications I checked are working fine. It's just the rqt applications that return this message. Could it be related to some Qt version that needs to be separately installed?

EranK gravatar image EranK  ( 2014-08-21 00:34:46 -0500 )edit

root@titan:~# rosrun rqt_graph rqt_graph

rqt_graph: Fatal IO error: client killed

root@titan:~# set | grep DIS

DISPLAY=i74930k:0.0 ROS_DISTRO=indigo

root@titan:~# xeyes & [1] 31942

root@titan:~#

logicmoo gravatar image logicmoo  ( 2014-11-21 23:37:38 -0500 )edit

I have a ground station computer with IP 134.59.129.159 and a odroid companion computer with IP 134.59.129.151. Both run ubuntu 14.04.

ssh odroid@134.59.129.151 in a terminal in the ground station, permit launch successfully rqt_plot, gedit, cutecom in a remote (the ground station). It works!

lhnguyen gravatar image lhnguyen  ( 2017-09-15 03:58:55 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-20 07:41:41 -0500

Seen: 1,262 times

Last updated: Aug 20 '14