hector slam launch error

asked 2014-08-19 05:22:40 -0500

unais gravatar image

I am installed the hector slam in my ubuntu 12.04 by following http://wiki.ros.org/hector_slam/Tutor... this tutorial.

Then I run

roslaunch hector_slam_launch tutorial.launch

and it producing the following error

[hector_geotiff_node-4] process has died [pid 8498, exit code 127, cmd nice -n 15 /opt/ros/hydro/lib/hector_geotiff/geotiff_node map:=/dynamic_map __name:=hector_geotiff_node __log:=/home/asimov/.ros/log/76e9ba38-2786-11e4-91d5-f4b7e2f15131/hector_geotiff_node-4.log].
log file: /home/asimov/.ros/log/76e9ba38-2786-11e4-91d5-f4b7e2f15131/hector_geotiff_node-4*.log
[ WARN] [1408443095.067044412]: No transform between frames /map and scanmatcher_frame available after 20.001574 seconds of waiting. This warning only prints once.

RVIZ is running but it showing the error no tf data.

After that I run

rosbag play Team_Hector_MappingBox_RoboCup_2011_Rescue_Arena.bag  --clock

but not showing it on the map

How can I get the map in rviz?

What will be the directory where geotiff file is saved. How can I get the geotiff file & image

Thanks in Advance

edit retag flag offensive close merge delete

Comments

add map in rviz panel and choose map topic.

bvbdort gravatar image bvbdort  ( 2014-08-19 06:54:38 -0500 )edit

Am having the same problem, any solutions?

Gabee gravatar image Gabee  ( 2016-08-03 07:59:55 -0500 )edit