Ask Your Question
0

Running rqt_gui plugins in Fuerte. [closed]

asked 2014-08-19 03:59:26 -0500

Eisenhorn gravatar image

Hello,

I am having troubles running the rqt_gui in ROS Fuerte. My system specs:

Ubuntu 12.04 LTS 3.11.0-26-generic ROS Fuerte

After launching the rqt_gui by running the rosrun command, I recieve the following error message:

Could not import "pyqt" bindings of qt_gui_cpp library - so C++ plugins will not be available:
Traceback (most recent call last):
  File "/opt/ros/hydro/lib/python2.7/dist-packages/qt_gui_cpp/cpp_binding_helper.py", line 43, in <module>
    import libqt_gui_cpp_sip
ImportError: /opt/ros/hydro/lib/python2.7/dist-packages/qt_gui_cpp/libqt_gui_cpp_sip.so: undefined symbol: _ZN3ros7package10getPluginsERKSsS2_RSt6vectorISsSaISsEEb

I have two ROS Versions installed. Fuerte and Hydro. The terminal were I started rqt_gui is set up for Fuerte Usage:

ROS_ROOT=/opt/ros/fuerte/share/ros
ROSLISP_PACKAGE_DIRECTORY=/opt/ros/fuerte/share/common-lisp/ros
ROS_PACKAGE_PATH=/home/user/ROS/fuerte_ws/moro_3rad:/home/user/ROS/fuerte_ws/RCPRG_laser_drivers:/home/user/ROS/fuerte_ws/taurob_simulation:/home/user/ROS/fuerte_ws/taurob_sensors:/home/user/ROS/fuerte_ws/sas_utils:/home/user/ROS/fuerte_ws/sas_ui_server:/home/user/ROS/fuerte_ws/sas_test:/home/user/ROS/fuerte_ws/sas_navigation:/home/user/ROS/fuerte_ws/sas_ecu_client:/opt/ros/fuerte/stacks:/opt/ros/fuerte/share:/opt/ros/fuerte/share/ros
ROS_MASTER_URI=http://localhost:11311
ROS_WORKSPACE=/home/user/ROS/fuerte_ws
ROSLISP_PACKAGE_DIRECTORIES=
ROS_DISTRO=fuerte
ROS_ETC_DIR=/opt/ros/fuerte/etc/ros

So why is it trying to access the hydro library. In /opt/ros/fuerte/lib/python2.7/dist-packages I couldn't find any qt_gui_cpp or similar folder. As soon as I try to load a plugin the GUI crashes. For fuerte I can only find this stack

ros-fuerte-rqt - rqt

Is there a way to make rqt_gui workout in Fuerte?

BR and thanks for any help

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Eisenhorn
close date 2019-12-20 03:05:26.008014

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-09-12 07:13:54 -0500

Dorian Scholz gravatar image

For me rqt is working fine in fuerte. I don't have hydro installed, only fuerte and groovy and there are no conflicts. It might be a problem in your ROS setup.

Can you check your PYTHONPATH environment variable to not contain any hydro paths. It should look similar to this when in a fuerte bash:

PYTHONPATH=/opt/ros/fuerte/lib/python2.7/dist-packages:/opt/ros/fuerte/lib/python2.7/dist-packages:
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-08-19 03:59:26 -0500

Seen: 344 times

Last updated: Sep 12 '14