Ask Your Question
2

Installing tum_ardrone with catkin_make

asked 2014-08-18 12:34:55 -0600

achery323 gravatar image

Hi,

I'm new to ROS and having trouble setting up tum_ardrone for use with the Parrot Drone Quadcopter. I've installed ROS Hyrdro on Ubuntu version 12.04 and followed all the beginner tutorials with no problems. I've installed the pre-requites but when I try to install the tum_ardrone package as told to on their wiki by running, I get problems when running the following line:

rosdep install tum_ardrone

It spits out the the following error.

ERROR: Rosdep cannot find all required resources to answer your query
Missing resource tum_ardrone
ROS path [0]=/opt/ros/hydro/share/ros
ROS path [1]=/opt/ros/hydro/share
ROS path [2]=/opt/ros/hydro/stacks

The link to the wiki with install instructions is here: link text The instructions extract is below.

cd catkin_ws/src
git clone https://github.com/tum-vision/tum_ardrone.git -b hydro-devel
cd ..
rosdep install tum_ardrone
catkin_make

Any suggestions would be greatly appreciated.

Thanks,

Jonathan

edit retag flag offensive close merge delete

Comments

I think the setup instructions assume that you've sourced the workspace before you begin.

ahendrix gravatar imageahendrix ( 2014-08-19 01:02:06 -0600 )edit

Thanks for the help, that fixed the ROS path errors, however it still can't find the resource tum_ardrone when running the line below. Do I have to manually tell rosdep where that folder is or something if it can't find it?

rosdep install tum_ardrone

From the tutorials I have seen using catkin_make though, they never use rosdep. They just git clone the link, go to the catkin_ws directory and then catkin_make. I've also tried this however the make fails as well.

achery323 gravatar imageachery323 ( 2014-08-19 06:19:53 -0600 )edit
1

From your catkin_ws directory, you may want to try: rosdep install --from-paths src --ignore-src instead.

ahendrix gravatar imageahendrix ( 2014-08-19 12:51:49 -0600 )edit

Okay, finally got it working so apologies for the late reply, I will post a solution to my question below in case other beginners have the same problem. Is there a way to not have to source the workspace every time I fire up my computer though?

achery323 gravatar imageachery323 ( 2014-08-21 12:34:15 -0600 )edit

You can edit your shell's startup script, (usually ~/.bashrc) to include the source command so that you don't have to type it by hand each time.

ahendrix gravatar imageahendrix ( 2014-08-21 13:24:47 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-08-21 12:38:48 -0600

achery323 gravatar image

If anyone else if having this same problem, I had two issues:

1) Sourcing the workspace: running the following line before attempting the instructions worked for me and got rid of the missing rospath errors. source ~/catkin-ws/devel/setup.bash

2) Running rosdep update after the git clone command - rosdep needed to be update of the package just downloaded into the folder to recognise it was there.

A big thanks to ahendrix to helping with this! Definitely got the ball rolling in the right direction!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-18 12:22:13 -0600

Seen: 1,677 times

Last updated: Aug 21 '14