Ask Your Question
0

Trouble installing nmea_navsat_driver package?

asked 2014-08-14 13:23:15 -0500

randylewis7 gravatar image

Hello, I'm currently trying to set up a GPS receiver and base station my boss purchased to work in ROS. It is a trimble Ag GPS 542 GNSS receiver ( http://ssmgps.com/pdf/AGPB_AgGPS542_B.. . ). It looks like the deivce can work in NMEA-0183 sentences, and thus that it should be compatible with the nmea_navsat_driver ROS package, found here: http://wiki.ros.org/nmea_navsat_driver , but I am encountering some installation issues.

I have extracted the package into my catkin_ws/src directory using

 git clone https://github.com/ros-drivers/nmea_navsat_driver

Then I run catkin_make, and get the following response:

CMake Error at /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:75 (find_package): Could not find a configuration file for package roslint.

Set roslint_DIR to the directory containing a CMake configuration file for roslint. The file will have one of the following names:

roslintConfig.cmake roslint-config.cmake

Call Stack (most recent call first): nmea_navsat_driver/CMakeLists.txt:4 (find_package)

CMake Error at nmea_navsat_driver/CMakeLists.txt:23 (roslint_python): Unknown CMake command "roslint_python".

I don't know what roslint_DIR is, and can't find anything about it online, but I did try searching my computer for both roslintConfig.cmake and roslint-config.cmake (no results for either). Anyone know what could be going wrong/how to fix it?

edit retag flag offensive close merge delete

Comments

I'm not sure if I modified everything I should have from your example, but I tried

rosdep install --from-paths ~/catkin_ws/src --ignore-src --rosdistro hydro -y

And it told me "ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: toro: Cannot locate rosdep definition for [ncurses++]" Ncurses is something I'm using in another executable in the same project (that I don't care about anymore). I tried commenting out the CMakeLists reference to that executable, but it didn't change the error.

randylewis7 gravatar imagerandylewis7 ( 2014-08-14 15:10:36 -0500 )edit

another option is to create another worskpace and clone only the gps driver there. Can you try that?

Gary Servin gravatar imageGary Servin ( 2014-08-14 15:29:00 -0500 )edit

Alright, made a catkin_ws2 right next to the first one (had to check out the ros tutorials again). Then I added the path to my ROS_PACKAGE_PATH, cloned it into the src directory, and catkin_made. Unfortunately, I get exactly the same error.

randylewis7 gravatar imagerandylewis7 ( 2014-08-14 16:41:05 -0500 )edit

Actually I get what you mean now. I ran the rosdep install line in my catkin_ws2 and it worked. Now catkin_make builds successfully and I can run the executable! So what exactly did that line do? I don't understand the --from-paths src and --ignore-src parts.

randylewis7 gravatar imagerandylewis7 ( 2014-08-14 16:48:33 -0500 )edit

you can read what they mean in the installation guide from source for indigo (section 2.1.2).

Gary Servin gravatar imageGary Servin ( 2014-08-15 00:02:26 -0500 )edit

Ok, thanks!

randylewis7 gravatar imagerandylewis7 ( 2014-08-19 13:13:29 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
0

answered 2014-08-14 13:37:54 -0500

updated 2014-08-15 00:03:37 -0500

did you tried checking the dependencies before catkin_make? for example,

rosdep install --from-paths src --ignore-src --rosdistro indigo -y

another option is to create another worskpace and clone only the gps driver there.

EDIT: Added second part from the comments.

edit flag offensive delete link more

Comments

Initialized a second catkin_ws, git cloned the package into the src directory, and ran the suggested line in it: rosdep install --from-paths ~/catkin_ws/src --ignore-src --rosdistro hydro -y

Then catkin built and the installation is complete.

randylewis7 gravatar imagerandylewis7 ( 2014-08-19 13:16:17 -0500 )edit
0

answered 2019-02-10 07:16:40 -0500

tobidelbruck gravatar image

I couldn't make any of the above work correctly on RPi.

What worked for me was to clone roslint ( http://wiki.ros.org/roslint ) to my catkin workspace src folder using the git URL https://github.com/ros/roslint just like any other package and then I could successfully run catkin_make.

I had previously cloned nmea_navsat_driver to my src folder

Specifically

cd ~/ros_catkin_ws (or whereever your workspace is located)
cd src
git clone https://github.com/ros/roslint
cd ..
catkin_make
edit flag offensive delete link more
0

answered 2014-08-15 01:41:21 -0500

ahendrix gravatar image

Does installing from debs work?

sudo apt-get install ros-hydro-nmea-navsat-driver
edit flag offensive delete link more
0

answered 2017-02-15 20:14:16 -0500

angshumanG gravatar image
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-14 13:23:15 -0500

Seen: 1,792 times

Last updated: Feb 10