Ask Your Question
-1

Indigo on Ubuntu14.04 problem;point 1.3 set up your keys means?

asked 2014-08-13 14:41:21 -0500

omc gravatar image

updated 2014-08-13 15:30:53 -0500

tfoote gravatar image

Hello , I stuckup while installing Indigo. I did as per installation guidelines as shown in below link: http://wiki.ros.org/indigo/Installati...

I really did not understand guideline in "1.3 Set up your keys" . There is no proper explanation for this point. So I skipped this instruction and tried to proceeded with guideline "1.4 Installation" .

while installation I got this error :

admin51@admin51-ThinkPad-X201:~$ sudo apt-get install ros-indigo-desktop-full
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

Based on the response from terminal. What could be the problem ?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
4

answered 2014-08-13 15:33:20 -0500

The 1.3 step is referring to setting up keys for authenticating packages with the apt-get package manager using the apt-key utility. Basically if you skip this step, then every time you try and install ROS packages, your system will ask you if it's okay to install untrusted packages.

The error you placed in the question is likely completely unrelated. Apt-get (as well as aptitude, dpkg, synaptic, and likely others) use a "lock" system to ensure that the package manager can't be started if there is already an instance running (to avoid conflicting operations happening at the same time). Steps to try and fix the error:

  1. Try running your command again without doing anything. Perhaps the process that originally caused your error is now finished.
  2. If that doesn't work, there could be other instances of apt-get running that you are unaware of, or some program using the lock that you don't realize (like the Ubuntu software center). Try rebooting the computer and then try the command again. Or could also try the command sudo lsof /var/lib/dpkg/lock that could tell you if there is a process running that is using the lock file. If there is, you should see a printout telling you what the PID of the process is. You could manually kill this process using kill -9 PID.
  3. If you are still getting the same error message, there could be something wrong with the lock file itself. If you get to this step, the fixes are slightly more drastic. Edit your original post, and let us know that the above things did not work.
edit flag offensive delete link more

Comments

thanks a lot it working now

omc gravatar image omc  ( 2014-08-14 14:31:18 -0500 )edit
2

answered 2014-08-13 15:35:27 -0500

tfoote gravatar image

Your error message tells you the problem::

E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

You have something else holding the dpkg lock running. (Possibly synaptic or the Ubuntu Software Center)

Note skipping a step because you don't know what it does will usually make things fail. Once you resolve the problem of something else having the dpkg lock, you will not be able to install packages without the key in your keyring, provided by step 1.3.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-13 14:41:21 -0500

Seen: 697 times

Last updated: Aug 13 '14