ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Why does my robot rotates to the left even when the goal is in its right?

asked 2014-08-10 07:02:57 -0500

AmiraJr gravatar image


I have a non holonomic robot, "Seekur Jr." I set up the navigation stack, and I am using TrajectoryPlannerROS as a base local planner, with DWA set to true.

The path planning and obstacle avoidance works just fine , but when it moves the robot shows an incorrect behavior: When I set the goal to the right of the robot, it first makes a full turn to the left and then starts moving towards the goal. However when I set the goal to the left or in front of it, it goes directly there. So it seems the robot always needs to make a left turn first.

I debugged every part of the project(acml, odom,transformation) and the error doesn't seem to be related to them. I also checked all the parameters and matched them to the default parameters.

I have started to tune the parameters and I believe the error is caused by them however I am not sure which parameter to adjust. I have already followed a tuning guide and used all the default parameters.

I also tried all the solutions on the internet but non worked or solved my problem.

Please guide me on this issue. I have already spent close to two months trying to figure it out.

I'd be glad and thankful to your suggestions.

edit retag flag offensive close merge delete


Which ROS version are you using? With the turtlebot indigo code this doesn't happen anymore, but I have no hydro installed, so I cannot check.

jorge gravatar image jorge  ( 2014-08-11 07:30:55 -0500 )edit

@jorge That was the problem , I had to set the min_vel_theta to -1.0. Thank you so much, you saved the project

AmiraJr gravatar image AmiraJr  ( 2014-08-12 01:41:34 -0500 )edit

Cool. I make an answer so this can be useful for others

jorge gravatar image jorge  ( 2014-08-12 02:08:09 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-08-11 07:33:07 -0500

jorge gravatar image

I remember now that in older navistack configurations there was a problem with min_vel_theta and max_vel_theta parameters, where the former must be negative. Type rosparam get /move_base/TrajectoryPlannerROS/min_vel_theta to ensure that's not your problem.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-08-10 07:02:57 -0500

Seen: 660 times

Last updated: Aug 10 '14