Obstacle doesn't show on rviz [closed]

asked 2014-08-08 20:02:30 -0500

Ken_in_JAPAN gravatar image

updated 2014-08-10 00:32:13 -0500

I face a problem that obstacles doesn't show on rviz. According to some answers, there are some changes from Hydro. costmap_2d::InflationLayer, costmap_2d::ObstacleLayer and FootprintLayer are added. When I execute rostopic list, I can look at /local_costmap/obstacles and local_costmap/inflated_obstacles. But they doesn't publish anything. So, Could anyone tell me how to show obstacle grid on rviz? Thank you in advance! image description

If I use a default launch on turtlebot_navigation/tutorial, I can do that. image description

If I perform rosrun rviz rviz instead of roslaunch turtlebot_rviz_launchers view_navigation --screen, I can show next image.

image description

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2018-01-30 22:13:10.384192

Comments

Ken, Are you using the default configuration of the navigation stack explained here : http://wiki.ros.org/navigation/Tutori... ?

If it helps, you can use "rosrun rqt_reconfigure rqt_reconfigure" to dynamically enable/disable the different layers and see the effect.

al-dev gravatar imageal-dev ( 2014-08-09 02:02:43 -0500 )edit

Thanks @al-dev. Actually, I have changed a configuration of turtlebot. I mean that my turtlebot have kinect on top plate and hokuyo on middle plate. If I follow /turtlebot_navigation/tutorial, I can do that.

Ken_in_JAPAN gravatar imageKen_in_JAPAN ( 2014-08-09 09:58:31 -0500 )edit

Ken, by "the obstacle" are you referring to that black rectangular shape? If so, have you checked that the "obstacle_range" and "window size" parameters of your costmaps are set to a large enough value? The default should be 2.5m, which is just about the distance to the black shape on the map.

al-dev gravatar imageal-dev ( 2014-08-11 05:43:23 -0500 )edit

Hi, @al-dev, Practical depth is 3.5m and physical depth is 4.0m in case of kinect? Do you say that you should set obstacle_range 3.5m? By the way, black rectangular is turtlebot2.

Ken_in_JAPAN gravatar imageKen_in_JAPAN ( 2014-08-11 19:07:25 -0500 )edit

hi,I also have the same trouble.Can you tell the reason?Thank you very much

Jie Sky gravatar imageJie Sky ( 2015-03-25 01:09:38 -0500 )edit