Ask Your Question
0

[hydro] Error in move_base.launch

asked 2014-08-04 09:26:50 -0600

Moda gravatar image

updated 2014-08-04 10:13:27 -0600

When I launch my move_base.launch, ( http://wiki.ros.org/navigation/Tutori... ) , I got this error :

Trajectory Rollout planner initialized with param meter_scoring not set. Set it to true to make your settins robust against changes of costmap resolution

This is my base_local_planner.yaml file

TrajectoryPlannerROS:
  max_vel_x: 0.01 #0.45
  min_vel_x: 0.005
  max_rotational_vel: 0.02 #1.0
  min_in_place_rotational_vel: 0.002 #0.4

  acc_lim_th: 0.01 #0.06 #3.2
  acc_lim_x: 0.01 #0.05 #2.5
  acc_lim_y: 0.5 #2.5

  holonomic_robot: false
  dwa: true
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-08-04 20:33:17 -0600

To get rid of that message you should set the parameter meter_scoring to either true or false, depending on your preferences. At the end of your base_local_planner.yaml add:

meter_scoring: true

or

meter_scoring: false

It is recommended to use meter scoring (meter_scoring: true) when you expect that the resolution of your map might change.

edit flag offensive delete link more

Comments

Thank you !!

Moda gravatar image Moda  ( 2014-08-05 02:13:35 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-04 09:26:50 -0600

Seen: 2,879 times

Last updated: Aug 04 '14