ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
3

E: unable to locate package ros-indigo-desktop-full

asked 2014-08-03 07:22:49 -0600

joshpj1 gravatar image

I have followed the ROS site's instructions on installing ROS indigo on Trusty Ubuntu through virtualbox, but I get this error. I know indigo is now released, which was the previous problem for a couple of questions

edit retag flag offensive close merge delete

Comments

Did you add the ROS repository to your list of repos

Arkapravo gravatar imageArkapravo ( 2014-08-03 11:27:23 -0600 )edit

More specifically, can you paste the result of cat /etc/apt/sources.list.d/ros-latest.list' command?

130s gravatar image130s ( 2014-11-20 17:46:28 -0600 )edit

@130s Not sure if this question is still active but worth a shot. I tried installing jade on my 14.04 and it is not allowing me to setup my sources. Whenever I try the command to setup it up as the tutorial says my terminal simply breaks a new line and does nothing.

preto gravatar imagepreto ( 2017-02-28 22:33:24 -0600 )edit

And cat /etc/apt/sources.list.d/ros-latest.list does the same... breaks a line and does nothing, forcing me to Crtl + C

preto gravatar imagepreto ( 2017-02-28 22:34:27 -0600 )edit

@preto please open a new question. Comment sections is not supposed to ask a new one (and you won't get as much attention).

130s gravatar image130s ( 2017-03-01 10:30:22 -0600 )edit

4 Answers

Sort by ยป oldest newest most voted
1

answered 2014-08-03 21:56:52 -0600

Mehdi. gravatar image

That is weird if you followed the instructions. Did you do all of those steps?

sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu trusty main" > /etc/apt/sources.list.d/ros-latest.list'

wget https://raw.githubusercontent.com/ros/rosdistro/master/ros.key -O - | sudo apt-key add -

sudo apt-get update

sudo apt-get install ros-indigo-desktop-full
edit flag offensive delete link more

Comments

Thanks, I'm newer to Linux so reading the instructions I wasn't sure what the commands for each step were. So writing them out as commands really helped. It's installing for me now.

PaulMakesThings gravatar imagePaulMakesThings ( 2015-10-07 19:06:29 -0600 )edit

glad it helped.

Mehdi. gravatar imageMehdi. ( 2015-10-14 06:32:06 -0600 )edit
1

answered 2015-04-29 09:43:29 -0600

tosandip gravatar image

I am getting the same error. I tried the 4 steps and when I do :

sudo apt-get install ros-indigo-desktop-full

I get the error.

I am copy-pasting the command on the http://wiki.ros.org/indigo/Installati... , hence do not see any typos happening.

When I check for the ros-latest.list, I get the following output:

....@ubuntu:~$ cat /etc/apt/sources.list.d/ros-latest.list deb http://packages.ros.org/ros/ubuntu vivid main

Let me know what might be going on.

I am running ubuntu on vmware player

edit flag offensive delete link more

Comments

you should use Ubuntu 14.04 for ROS indigo (trusty tahr). Or install Ros Jade on Ubuntu 15.04 (vivid)

Mehdi. gravatar imageMehdi. ( 2016-08-23 03:44:10 -0600 )edit
1

answered 2014-11-20 12:06:15 -0600

zurish gravatar image

The same thing happens to me. I followed the steps strictly, but it still can not be found.

edit flag offensive delete link more

Comments

I mistaken "packages.ros.org" as "package.ros.org" and had the same error message. After fixed it, it installed smoothly. check urs

sunoval gravatar imagesunoval ( 2015-04-23 00:26:45 -0600 )edit
0

answered 2016-07-29 11:22:40 -0600

marwa eldiwiny gravatar image

Hey folks

I still have the same problem, i am using ubuntu 15.04 64 bit

eldiwiny@eldiwiny-HP-2000-Notebook-PC:~$ sudo apt-get install ros-indigo-desktop-full Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: ros-indigo-desktop-full : Depends: ros-indigo-desktop but it is not going to be installed Depends: ros-indigo-perception but it is not going to be installed Depends: ros-indigo-simulators but it is not going to be installed E: Unable to correct problems, you have held broken packages.

edit flag offensive delete link more

Comments

use Ubuntu 14.04 for Indigo or 16.04 for Kinetic. I think in 15.04 Ros Jade would work. And you should open a new question and not ask a question as "answer" to another question.

Mehdi. gravatar imageMehdi. ( 2016-08-01 08:30:28 -0600 )edit

Thanks Mehdi, I am so sorry I am newbie. Fine it works 15.04 Vivid ROS Jade.

marwa eldiwiny gravatar imagemarwa eldiwiny ( 2016-08-02 04:32:47 -0600 )edit

Thanks Medhi. It is exactly that with Ubuntu 16.04, we must install ROS Kinetic.

lhnguyen gravatar imagelhnguyen ( 2016-08-23 02:56:26 -0600 )edit

Hello, I installed ROS Kinetic (use ubuntu 16.04) By following the following link http://wiki.ros.org/kinetic/Installat... Now i want to continue to instal Turtlebot Installation (link http://wiki.ros.org/turtlebot/Tutoria... ) I have the same problem E: unable

emna gravatar imageemna ( 2017-01-02 14:55:01 -0600 )edit

Is there another specific link for kinetic? what is the difference between kinetic and Indigo (more option in Indigo?) (i am a beginner)

emna gravatar imageemna ( 2017-01-02 15:00:45 -0600 )edit
1

just replace the word "indigo" by "kinetic" in all the turtlebot packages you want to install.

Mehdi. gravatar imageMehdi. ( 2017-01-17 06:04:28 -0600 )edit

Thank you Mehdi..I will reinstall ubuntu (14.04 or 16.04) ... What is more recommended now ROS indigo or ROS kinetic .. There is more documentation on ROS indigo ... By cons, kinetic is the newest .. Does it contain more features? What you advise me: ubuntu 14.04=> indigo or ubuntu 16.04 => kinetic

emna gravatar imageemna ( 2017-01-17 08:05:41 -0600 )edit

I encountered the same problem while installing indigo and it turns out that indigo is only supported on 14.04 which wasn't the case with me.

pulkitkatdare gravatar imagepulkitkatdare ( 2018-10-05 18:13:51 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-08-03 07:22:49 -0600

Seen: 46,881 times

Last updated: Aug 03 '14