Problem running mapstitch

asked 2014-07-30 09:21:30 -0500

gerhenz gravatar image


I'm having some problems trying to run the mapstitch command. I'm trying to use the same command shown in the answers of this question.

I'm new to ROS and for me it's not totally clear how to install a package when it's not possible to use the apt-get install command.

Here is what I've tried:

  1. Download package files from here, saving in /catkin_ws/src/. I didn't know which branch to download. I ended up choosing the master one

  2. Ran catkin_make under top level directory of catkin workspace

The problem is that there isn't a bin folder inside the package folder, so the code to run mapstitch doesn't works.

I've also tried using an alternative command rosrun mapstitch-master mapstitch [...] but it doesn't work. It outputs an error that says: Couldn't find executable named mapstitch....

One strange thing that I noticed is that when I run catkin_make it displays on the terminal all the packages that have been built. However, the mapstitch package is not shown.

I think the solution may be something very simple, but I've tried lots of different things with no success. Does anyone know what could be the solution to my problem?

I'm using ROS Hydro.


edit retag flag offensive close merge delete


this package is old, it cannot be built directly with catkin, it has to be catkinized first. I'm facing the same issue trying to catkinize it

hasauino gravatar image hasauino  ( 2016-07-04 10:53:19 -0500 )edit

You can still use rosbuild on top of Hydro, and even Kinetic. Rosbuild packages can depend on catkin packages (always in a separate workspace), but catkin packages cannot depend on rosbuild packages.

joq gravatar image joq  ( 2016-07-05 09:55:48 -0500 )edit