Ask Your Question
1

cannot start roscore

asked 2014-07-16 10:32:09 -0500

robospace gravatar image

this is error i got when i start the roscore.

[rosout-1] process has died

why is this happening?.

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted
0

answered 2014-07-18 00:28:01 -0500

Dirk Thomas gravatar image

Is that happening for Indigo for you, too? If yes it might be related to https://github.com/ros/ros_comm/pull/465

edit flag offensive delete link more
2

answered 2014-12-25 07:49:55 -0500

MartinHummel gravatar image

I' m running ROS Indigo on a rasberry raspian jessie installation. After evoking roscore, I' getting:

process[rosout-1]: started with pid [955] [rosout-1] process has died [pid 955, exit code -4, cmd /opt/ros/indigo/lib/rosout/rosout __name:=rosout __log:=/home/pi/.ros/log/ec132a8c-8c3b-11e4-834d-b827eb2156d2/rosout-1.log]. log file: /home/pi/.ros/log/ec132a8c-8c3b-11e4-834d-b827eb2156d2/rosout-1*.log [rosout-1] restarting process

Any idea, to what this problem is related?

Thanks

edit flag offensive delete link more
1

answered 2014-07-17 09:00:54 -0500

grim gravatar image

I had the same error using the latest ROS Indigo build with an uptodate Ubuntu 14.04.

roscore

yielded:

started roslaunch server http://benni-notebook:58480/
ros_comm version 1.11.6


SUMMARY
========

PARAMETERS
 * /rosdistro: indigo
 * /rosversion: 1.11.6

NODES

auto-starting new master
process[master]: started with pid [22300]
ROS_MASTER_URI=http://benni-notebook:11311/

setting /run_id to 6e5bfafc-0db4-11e4-ba26-1867b02b12d1
process[rosout-1]: started with pid [22313]
started core service [/rosout]
[rosout-1] process has died [pid 22313, exit code -11, cmd /opt/ros/indigo/lib/rosout/rosout __name:=rosout __log:=/home/benni/.ros/log/6e5bfafc-0db4-11e4-ba26-1867b02b12d1/rosout-1.log].
log file: /home/benni/.ros/log/6e5bfafc-0db4-11e4-ba26-1867b02b12d1/rosout-1*.log
[rosout-1] restarting process
process[rosout-1]: started with pid [22320]
[rosout-1] process has died [pid 22320, exit code -11, cmd /opt/ros/indigo/lib/rosout/rosout __name:=rosout __log:=/home/benni/.ros/log/6e5bfafc-0db4-11e4-ba26-1867b02b12d1/rosout-1.log].
log file: /home/benni/.ros/log/6e5bfafc-0db4-11e4-ba26-1867b02b12d1/rosout-1*.log
[rosout-1] restarting process

Strangely enough the problem only occured while I was connected to a VPN (using NetworkManager). So I could bypass the issue by simply starting the roscore while not beeing connected to a VPN. I dont know the reason for this behaviour but I did a

gdb rosout

    Starting program: /opt/ros/indigo/lib/rosout/rosout 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7b41cc7 in ros::Transport::Transport() () from /opt/ros/indigo/lib/libroscpp.so
(gdb) bt
#0  0x00007ffff7b41cc7 in ros::Transport::Transport() () from /opt/ros/indigo/lib/libroscpp.so
#1  0x00007ffff7b4d1e0 in ros::TransportTCP::TransportTCP(ros::PollSet*, int) ()
   from /opt/ros/indigo/lib/libroscpp.so
#2  0x00007ffff7b3c828 in ros::ConnectionManager::start() ()
   from /opt/ros/indigo/lib/libroscpp.so
#3  0x00007ffff7b5f049 in ros::start() () from /opt/ros/indigo/lib/libroscpp.so
#4  0x00007ffff7b39d51 in ros::NodeHandle::construct(std::string const&, bool) ()
   from /opt/ros/indigo/lib/libroscpp.so
#5  0x00007ffff7b3a03f in ros::NodeHandle::NodeHandle(std::string const&, std::map<std::string, std::string, std::less<std::string>, std::allocator<std::pair<std::string const, std::string> > > const&) () from /opt/ros/indigo/lib/libroscpp.so
#6  0x0000000000407ca1 in main ()
edit flag offensive delete link more

Comments

Same for me: I get the same errors when starting up a roscore while I'm connected to a VPN. Works fine without VPN.

Stephan gravatar imageStephan ( 2014-07-17 11:08:54 -0500 )edit

I'am not connected to VPN but still i get this message

robospace gravatar imagerobospace ( 2014-07-18 11:26:33 -0500 )edit
0

answered 2014-07-16 10:33:29 -0500

DevonW gravatar image

Is there any other error messages? With my experience I can say that it requires a restart of the terminal (close all your terminals as there might be a background process where the node is still alive/stuck/hasn't been cleared yet) OR is already running on your system/network.

edit flag offensive delete link more

Comments

i am getting this error even after doing that, so i did logout and login to my system ,but still i am getting that error.

robospace gravatar imagerobospace ( 2014-07-16 11:01:01 -0500 )edit

Please post the whole output when you do "roscore"

McMurdo gravatar imageMcMurdo ( 2014-07-16 14:46:53 -0500 )edit

Did you set up ROS Master? This is written on this page( http://wiki.ros.org/roscore ).

Ken_in_JAPAN gravatar imageKen_in_JAPAN ( 2014-07-16 18:30:56 -0500 )edit

This is full error i got [rosout-1] process has died [pid 19819, exit code -11, cmd /opt/ros/indigo/lib/rosout/rosout __name:=rosout __log:=/home/ben/.ros/log/acd97af6-0e96-11e4-b415-6bb9d06e5c52/rosout-1.log]. log file: /home/ben/.ros/log/acd97af6-0e96-11e4-b415-6bb9d06e5c52/rosout-1*.log

robospace gravatar imagerobospace ( 2014-07-18 11:24:14 -0500 )edit
0

answered 2014-07-22 12:51:15 -0500

Biren gravatar image

hey guys I am also getting the same error.....I am too not connected to VPN and no other process running in terminal, still getting this error.....

[rosout-1] restarting process process[rosout-1]: started with pid [14737] [rosout-1] process has died [pid 14737, exit code -11, cmd /opt/ros/indigo/lib/rosout/rosout __name:=rosout __log:=/home/biren/.ros/log/c628db32-115c-11e4-9694-5da91953c25a/rosout-1.log]. log file: /home/biren/.ros/log/c628db32-115c-11e4-9694-5da91953c25a/rosout-1*.log

plz help me with this

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-07-16 10:32:09 -0500

Seen: 2,204 times

Last updated: Dec 25 '14