Ask Your Question
2

Indigo rqt_image_view depends on build_isolated

asked 2014-07-15 06:56:37 -0500

J.M.T. gravatar image

updated 2014-07-15 17:36:49 -0500

demmeln gravatar image

Why does rqt_image_view still depend on the workspace that was used for building it although it was installed to /opt/ros/indigo? Is that desirable? What can I do to fix this?

 rosrun rqt_image_view rqt_image_view                                                                                                                              
    Traceback (most recent call last):
      File "/opt/ros/indigo/lib/rqt_image_view/rqt_image_view", line 8, in <module>
        sys.exit(main.main(sys.argv, standalone='rqt_image_view'))
      File "/opt/ros/indigo/lib/python2.7/site-packages/rqt_gui/main.py", line 59, in main
        return super(Main, self).main(argv, standalone=standalone, plugin_argument_provider=plugin_argument_provider, plugin_manager_settings_prefix=str(hash(os.environ['ROS_PACKAGE_PATH'])))
      File "/opt/ros/indigo/lib/python2.7/site-packages/qt_gui/main.py", line 336, in main
        from python_qt_binding import QT_BINDING
      File "/Users/tatsch/ros_catkin_ws/build_isolated/python_qt_binding/bdist.macosx-10.9-intel/egg/python_qt_binding/__init__.py", line 55, in <module>
      File "/Users/tatsch/ros_catkin_ws/build_isolated/python_qt_binding/bdist.macosx-10.9-intel/egg/python_qt_binding/binding_helper.py", line 262, in <module>
      File "/Users/tatsch/ros_catkin_ws/build_isolated/python_qt_binding/bdist.macosx-10.9-intel/egg/python_qt_binding/binding_helper.py", line 81, in _select_qt_binding
      File "/Users/tatsch/ros_catkin_ws/build_isolated/python_qt_binding/bdist.macosx-10.9-intel/egg/python_qt_binding/binding_helper.py", line 147, in _load_pyqt
      File "/usr/local/lib/python2.7/site-packages/PyQt4/Qwt5/__init__.py", line 32, in <module>
        from Qwt import *
    RuntimeError: the sip module implements API v11.0 to v11.1 but the PyQt4.Qwt5.Qwt module requires API v10.1
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-07-15 09:45:26 -0500

demmeln gravatar image

updated 2014-08-05 07:28:15 -0500

I don't think this actually depends on those files. Maybe it is just the source path baked into compiled python paths. Try removing / renaming that build dir. Fr me this results in the same error.

Now it seems we need to update the homebrew formula for pyqt to the 11.1 release, but it gives me a linker error...

EDIT: See hombrew issue https://github.com/Homebrew/homebrew/...

EDIT 2: I confirmed that the path referring to build is indeed baked into the installed compile python files, which kind of makes sense. So this is not a dependency to the build folder and the error is something else, namely outdated pyqt. Unfortunately there seems to be a linking issue for the recent pyqt version on OS X / clang, see the above github issue.

Update: It seems we have been able to fix the PyQT formula. With the current version in that pull request I can run rqt successfully. The formula will hopefully get merged into homebrew soon.

Update2: PyQt 4.11.1 has been released into homebrew. After brew update and subsequent brew upgrade pyqt, you should be able to run the GUI. Maybe you need to also brew reinstall pyqwt after upgrading pyqt.

edit flag offensive delete link more

Comments

When renaming it back to ros_catkin_ws it still results in the same error. No wonder, there is nothing inside ~/ros_catkin_ws/build_isolated/python_qt_binding/bdist.macosx-10.9-intel

J.M.T. gravatar image J.M.T.  ( 2014-07-15 10:20:25 -0500 )edit

I don't think the error is related to the contents of that directory. The python code is being executed evem though the files are not in that directory, as you can see from the stacktrace. I think this is purely an issue of PyQt being outdated and the wrong stack trace ...

demmeln gravatar image demmeln  ( 2014-07-15 10:49:56 -0500 )edit

... is due to the way the python-qt-bindings module is compiled.

demmeln gravatar image demmeln  ( 2014-07-15 10:50:05 -0500 )edit

Thanks demmeln, this will surely fix it, unfortunately now i can't install indigo anymore because rosdep is broken :(

J.M.T. gravatar image J.M.T.  ( 2014-08-05 09:25:55 -0500 )edit

If you have previously done the rosdep step for installing indigo I suspect you can skip it now.

demmeln gravatar image demmeln  ( 2014-08-05 10:28:44 -0500 )edit

Wow, all 219 packages compiled successfully. Never had such a painless ROS compile and all thanks to you Nikolaus!

J.M.T. gravatar image J.M.T.  ( 2014-08-05 16:30:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-15 06:56:37 -0500

Seen: 451 times

Last updated: Aug 05 '14