Ask Your Question
0

ax2550 node fails to connect to ax2550?

asked 2014-07-14 16:14:17 -0600

randylewis7 gravatar image

updated 2014-07-16 11:57:52 -0600

Hello, I'm using a ROS driver for the ax2550 motor controller found here:

https://github.com/wjwwood/ax2550

(I couldn't figure out the actual download, so I just created my own project and copied the text into each file, then catkin_made. I don't think this is the source of my problems, since it compiled, and worked for a similar device driver that I got working just yesterday.)

I have plugged the device into a serial-->usb converter, which then goes into my computer. However, when I run the node using:

rosrun ax2550 ax2550_node /dev/ttyUSB0 (this is the port its connected to)

I get the following response:

[ INFO] [1405371811.620859117]: AX2550 connecting to port /dev/ttyUSB0
[ERROR] [1405371811.621207096]: Failed to connect to the AX2550: IO Exception (13): Permission denied, file /tmp/buildd/ros-hydro-serial-1.1.7-0precise-20140617-0339/src/impl/unix.cc, line 150.
[ INFO] [1405371811.621317396]: Will try to reconnect to the AX2550 in 5 seconds.

It looks like this is a permissions error (despite the fact that I am the administrator), but I don't know for sure and if it is I don't know how to change these permissions. Anyone got any ideas?

Thanks

New info:

I ran the line sudo chmod 777 /dev/ttyUSB0, which solved the error I was initially having. However, I am now encountering a new error when I try to run the node: [ INFO] [1405453884.235150040]: AX2550 connecting to port /dev/ttyUSB0 [ERROR] [1405453886.236099864]: Failed to connect to the AX2550: Synchronization Exception: did not receive an R/C message after reset, file /home/randy/catkin_ws/src/toro/src/ax2550.cpp, line 315. [ INFO] [1405453886.503068921]: Will try to reconnect to the AX2550 in 5 seconds. Any idea what could be causing this one?

edit retag flag offensive close merge delete

Comments

You can use 'git clone URL' to create a local copy of the repository (see also the 'HTTPS clone url' box at the bottom right on the repository page. You might benefit from following a tutorial on git(hub), such as http://readwrite.com/2013/09/30/understanding-github-a-journey-for-beginners-part-1.

gvdhoorn gravatar imagegvdhoorn ( 2014-07-15 02:10:14 -0600 )edit

Thanks. I checked this out and it is a much easier method of installing github stuff

randylewis7 gravatar imagerandylewis7 ( 2014-07-15 14:56:45 -0600 )edit

@randylewis7 if you are still having trouble getting this to work you might update your question with new information.

William gravatar imageWilliam ( 2014-07-15 15:55:25 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-07-14 21:05:49 -0600

updated 2016-10-26 10:26:12 -0600

Make sure you have dialout access. Try sudo chmod 766 /dev/YOURPORT. A colleague of mine had a similar issue.

edit flag offensive delete link more

Comments

That did the trick, thanks. I ran the line sudo chmod 777 /dev/ttyUSB0, which solved the error I was telling you about initially. However, I am now encountering a new error when I try to run the node: [ INFO] [1405453884.235150040]: AX2550 connecting to port /dev/ttyUSB0 [ERROR] [1405453886.236099864]: Failed to connect to the AX2550: Synchronization Exception: did not receive an R/C message after reset, file /home/randy/catkin_ws/src/toro/src/ax2550.cpp, line 315. [ INFO] [1405453886.503068921]: Will try to reconnect to the AX2550 in 5 seconds. Any idea what could be causing this one?

randylewis7 gravatar imagerandylewis7 ( 2014-07-15 14:56:12 -0600 )edit
1

answered 2016-10-20 15:45:22 -0600

RagingBit gravatar image

No need to sudo on the port. As tonybaltovski suggests you only need to be in the dialout group. I had a similar issue with the iRoomba create 2 and I fixed it by doing:

sudo adduser <your-username> dialout

and very,very,VERY important: don't forget to logout and login back on your machine for the changes to be applied :)

edit flag offensive delete link more

Comments

Thanks. This is a better solution than chmod-ing after every reconnect and a more secure solution than changing the permissions on the port in general.

EpicWolverine gravatar imageEpicWolverine ( 2017-01-04 19:34:16 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-14 16:14:17 -0600

Seen: 417 times

Last updated: Oct 26 '16