ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
0

Openni_launch cannot subscribe both to depth_registered and rgb

asked 2014-07-08 10:07:55 -0600

Xegara gravatar image

updated 2014-07-08 10:11:55 -0600

I installed ros-hydro-openni-launch to my Odroid-U3. When I ran

roslaunch openni_launch openni.launch

it successfully streams as I can see the topics send average at 30 fps via the command

rostopic hz /camera/rgb/image_rect_color

However, once I subscribe also to

rostopic hz /camera/depth_registered/hw_registered/image_rect_raw

Both of the subscribers do not receive any more images as shown below..

Is this a bug? I also downloaded the latest commit of openni_launch and openni_camera in the github. But it was still the same... But they DO WORK alone. But subscribing to both of them fails....

image description

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-08-05 13:27:47 -0600

ahubers gravatar image

Looking at Openni.launch shows:

  <!-- Use OpenNI's factory-calibrated depth->RGB registration? -->
  <arg name="depth_registration" default="false" />

meaning you need to instead run

roslaunch openni_launch openni.launch depth_registration:=true

Although you are reporting that depth_registration works without setting that argument to be true, which is odd. Regardless maybe this will fix the issue? worth a shot...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-08 10:07:55 -0600

Seen: 251 times

Last updated: Jul 08 '14