Ask Your Question
0

Ros on fedora can't communicate publisher/subscriber

asked 2014-07-03 04:10:38 -0500

Maya gravatar image

updated 2014-07-14 05:24:21 -0500

Hello,

I'm using the fedora repo given by @cottsay. I might be doing something stupid but it seems to me that the messages are not working fine.

if I do :

roscore

then

rostopic echo /search

then

rostopic pub -1 /search std_msgs/Bool 'data : False'

Nothing is received. I got the good number of node if I do a rosnode list and when using rostopic info search I can see a node subscribing to the topic. I might do something incredibly stupid, but for now I did not find what is the problem and I don't really know what to do to debug it...

EDIT : Still having that problem. This is my repolist :

$ yum repolist
Modules complémentaires chargés : langpacks, refresh-packagekit
bumblebee/20   
bumblebee-nonfree/20    
fedora/20/x86_64                       
google-talkplugin               
planetccrma/20/x86_64       
planetcore/20/x86_64         
rpmfusion-free/20/x86_64    
rpmfusion-free-updates/20/x86_64                                                
rpmfusion-nonfree/20/x86_64      
rpmfusion-nonfree-updates/20/x86_64                                         
russianfedora-free/20/x86_64                                 
russianfedora-free-updates/20/x86_64                              
russianfedora-nonfree/20/x86_64                                          
russianfedora-nonfree-updates/20/x86_64                                       
smd-ros-shadow-fixed/20/x86_64                                              
smd-ros-staging/20/x86_64                                                      
*updates/20/x86_64                                                              
virtualbox/20/x86_64

I did yum install ros-hydro-desktop-full. I think it might be depend on my computer and not on ros itself but I have no idea what causes this. Here is a screenshot of what I'm doing :

screenshot

And nothing is received.

Here is my .bashrc as well concerning hydro :

alias hydro='source /opt/ros/hydro/setup.bash && source /home/malcolm/ros_ws/catkin_hydro/devel/setup.bash && export EDITOR='nano' && export ROS_PACKAGE_PATH=/home/malcolm/ros_ws/catkin_hydro/src:/opt/ros/hydro/share:/opt/ros/hydro/stacks

and the env variable of my system :

declare -x ROSLISP_PACKAGE_DIRECTORIES="/home/malcolm/ros_ws/catkin_hydro/devel/share/common-lisp"
declare -x ROS_DISTRO="hydro"
declare -x ROS_ETC_DIR="/opt/ros/hydro/etc/ros"
declare -x ROS_MASTER_URI="http://localhost:11311"
declare -x ROS_PACKAGE_PATH="/home/malcolm/ros_ws/catkin_hydro/src:/opt/ros/hydro/share:/opt/ros/hydro/stacks"
declare -x ROS_ROOT="/opt/ros/hydro/share/ros"
declare -x ROS_TEST_RESULTS_DIR="/home/malcolm/ros_ws/catkin_hydro/build/test_results"

EDIT : It seems more like my system is strangely slow. I'v launch a bunch of node right now and each time I'm trying to have the tf with this command : cd /var/tmp && rosrun tf view_frames && evince frames.pdf I either have no tf data, or partial tf data, not always the sames... which makes me thing that it may just be very slow...

edit retag flag offensive close merge delete

Comments

1

Are you sure the command you posted is correct? The usage for `rostopic pub` is: ``` Usage: rostopic pub /topic type [args...] ``` so I used the command: ``` rostopic pub -1 /search std_msgs/Bool 'data : False' ``` which was successful. What are you trying to do with the `--`?

cottsay gravatar imagecottsay ( 2014-07-03 09:12:24 -0500 )edit

Woups I had the same thing again today... Just to be sure I just need : smd-ros-shadow-fixed/20/x86_64 and smd-ros-staging/20/x86_64 as repo or do I miss something ? I'm reinstalling it now...

Maya gravatar imageMaya ( 2014-07-11 06:15:27 -0500 )edit

I'm pretty sure you're right and it has nothing to do with the repo since after after some trying the problem tend to appear and go depending on when. When it's working it seem kinda slow to me compare to my ubuntu and I'm wondering if it has smthg to do with it. I'll try your suggestion next time.

Maya gravatar imageMaya ( 2014-07-14 04:55:56 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-07-14 04:20:35 -0500

I'm fairly confident that this has nothing to do with repos. The next time things act up, try exporting `ROS_IP=127.0.0.1` on each terminal and trying again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-03 04:10:38 -0500

Seen: 615 times

Last updated: Jul 14 '14