problem with move_base and server connection

asked 2014-06-30 18:12:55 -0500

Federico gravatar image

updated 2014-06-30 18:21:35 -0500

Hi all,

I'm having trouble with the "simple goals sending" in the navigation stack. I set up the navigation stack as suggested in the tutorials. I'm using a laser scanner and amcl to localize in a known environment. The navigation stack (without the "simple goals sending" action) is working well and I'm able to display on rviz the map, the robot position and the related particle clouds, costmaps etc and the localization is fine if I teleop the robot. However, If I create and run a node as described in the navigation tutorial SendingSimpleGoals I got the following behaviors:

  1. 99% of tests, the MoveBaseClient cannot connect to the server (I got the "Waiting for the move_base action server to come up" message for minutes).

  2. In the remaining 1% of the tests which happens only if (but not if) the simple_navigation_goals node is run before starting the navigation stack, MoveBaseClient managed to connect to the server (but after awhile), then sendGoal is invoked but no motion, and no return from rostopic echo /move_base/goal.

Am I missing something? Any suggestion?

Many thanks

edit retag flag offensive close merge delete

Comments

Are you running move_base and the action client node on the same computer or on separate computers?

ahendrix gravatar image ahendrix  ( 2014-06-30 18:36:34 -0500 )edit

I'm running roscore, the base_controller and the hokuyo_node the robot. I run amcl+move_base+action client node on my laptop. In one trial I received this errors/warns. [Error] Extrapolation Error looking up robot pose: Lookup would require extrapolation into the past. Requested time 1404204525.078275750 but the earliest data is at time 1404204525.378564581, when looking up transform from frame [base_footprint] to frame [map]. and then many of these warning messages [ WARN] : Unable to get starting pose of robot, unable to create global plan

Federico gravatar image Federico  ( 2014-07-01 03:45:23 -0500 )edit

I understand the problem. It's a networking issue. Indeed, I can ping the robot from my laptop and viceversa. From my laptop I can see the messages published by the robot but I *can't* echo the messages published by my laptop on the robot.

Federico gravatar image Federico  ( 2014-07-01 05:12:54 -0500 )edit

Did you set ROS_MASTER_URI and ROS_IP correctly?

BennyRe gravatar image BennyRe  ( 2014-07-01 07:53:26 -0500 )edit

Hi! I have a similar problem when trying to run navigation stack with RTABmap. I am running it on RPi3 and trying to visualize with Rviz on my laptop over WiFi. I get error "Cannot connect to move_base action server!" Any suggestions? Thanks.

Dox gravatar image Dox  ( 2018-03-28 13:27:25 -0500 )edit

@Dox please ask a new question.

ahendrix gravatar image ahendrix  ( 2018-03-28 15:56:50 -0500 )edit